Third party software and hardware support forums. > PoKeys

Pokeys problem

(1/2) > >>


I have tried to hook up my pokeys board to do some testing with Mach3.

When I program as an example pin 1 for x axis (left arrow or right arrow) and do a send to device, if I click on the menu at the top of mach3 screen, each menu start to open from left to right on a non stop way.

On the window screen, if I double click on a icon, instead of opening the software, it act as I right click and got the property window.

I tried with a NO switch and a NC switch and it does the same thing.

If I try without opening Mach3, it affect the computer and have to press reset or disconnect the pokey board to get control of my computer.


Please download and ind install latest software and user manual from
If problems will persist after upgrade, attach screenshot of PoKeys software.
Please read user manual.

best regards


Hi, I have downloaded the latest version.

The pokeys board act like if I hold the arrow key so I can do nothing.

I tried to use it to alternate between Mach3 screen.

Pin 1 = Alt +1     Pin 2 = Alt +2     Pin 3 = Alt + 3

When I hit button, the screen flash at high rate

Instead of doing something when I hit button, it does it all the time like if I hold the button. Tried NO pushbutton and NC pushbutton

Can you explain to me what mean Program  "Mach3 with port 10 pin 1-55"

There are some pins which need external puul ups when used as an input. Please check user manual.
Try to configure other inputs pins.



I have done some testing and every time I connect the Pokeys board and program a pin, I loose control of my computer.

It is like the board send a non stop signal(the one programmed) maybe 10 times per second.

I don't know what to do with this board, maybe just get rid of it and try another model.


[0] Message Index

[#] Next page

Go to full version