Hello Guest it is October 21, 2019, 04:52:58 PM

Author Topic: Freezing! Mach3Version D1.90.035 to 50? What's different from vn17?  (Read 8876 times)

0 Members and 1 Guest are viewing this topic.

Hi All,

Been running licenced vn of Mach3 1.9.017 (fantasic, I love Mach3) and its been completely stable for many hours of operation and survived many stupid inputs and cable disconnections from me as I built my 4axis stepper machine.

Recently upgraded to vn 35, 41 and now 50 and these have all been unstable on my PC. After 5 to 10 minutes, PC hangs and usually system eStops. Motors always stop. Doesn't matter if a programme is running or the machine is idle.

Sometime, in the hung state, I can press the hard eStop on the machine and the PC will instantly recover and I can re-set again. Strangely, the status box sometimes then says "Script Terminated" only when that happens. But, then about 5 mins later the PC will hang and have to hard re-set no matter what the machine was doing.

"Driver Watchdog Triggered" also comes up. When I turn watchdog off, makes no difference to hanging. Also, I messed with increased inputs debounce and that also makes no difference. As Vn17 works, I don't think I have noise. It is a simple setup but with well shielded and filtered inputs.

So, any idea what was changed in the code or the pulsing driver that my PC doesn't like from Vn17 to vn 35 onwards? Or is there a setting I need to change on my setup? Enhanced pulsing on or off makes no difference. When I go back to Vn17, all is well again.

I've been through the very useful optimisation text and the PC works great. P3 1gHz, 256Mb, but it is not in "Standard PC" mode. Is that critical for releases after Vn17? At the moment, I am not brave enough to change this and don't really understand what difference it actually makes. xml attached.

I would be really grateful for your help.

Thanks

Re: Freezing! Mach3Version D1.90.035 to 50? What's different from vn17?
« Reply #1 on: June 18, 2006, 10:37:36 PM »
sounds like you have something running in in the background... look under MSconfig and see if you can turn off processes.

That should do it!
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Freezing! Mach3Version D1.90.035 to 50? What's different from vn17?
« Reply #2 on: June 18, 2006, 10:54:55 PM »
Thanks Brian, I will check that tonight but there is not much running - maybe 12 or 14 processes. Is that normal?

Its Win 2k by the way. Is that an issue? Do later versions HAVE to run on XP?

Any idea why Vn17 is always stable?

Sorry for so many questions. I will post a pic of my machine one day - its wood and aluminium but engineered for high stiffness - it will cut steel - maybe... Should find out soon!

Thanks!

Richard.
Re: Freezing! Mach3Version D1.90.035 to 50? What's different from vn17?
« Reply #3 on: June 19, 2006, 08:29:25 AM »
Hi Brian, attached is what I have running with Win2k before I start Mach3 (ignore firefox!).

I followed the optimisation as best I could, I don't think there is much else I can do without? What do you think?

Any idea why 17 would be stable with this setup and not vn35 to 50?

Could it be my Prn port settings - any basic settings we should use?

Or is this a "not running Standard PC problem"? But not sure why IRQs would change after windows starts?

Thanks, Richard.

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Freezing! Mach3Version D1.90.035 to 50? What's different from vn17?
« Reply #4 on: June 19, 2006, 09:37:46 AM »
Hi:

 Doesnt sound liek com settings or anything. Run Mach3Turn...just as a test. Does it hang after 5 minutes of sitting there..

Art
Re: Freezing! Mach3Version D1.90.035 to 50? What's different from vn17?
« Reply #5 on: June 20, 2006, 09:39:15 AM »
Hi Art,

Ah ha, Mach3Turn Vn50 does not hangup. OK for over 1h jogging and resetting and so on. No Problems. But Mach3Mill - hung after 5 mins again. ???

Sometimes, PC comes back after hanging but most times just freezes.

Is there some script always running with Mach3Mill that is different with Mach3Turn?

Thanks

Richard.

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Freezing! Mach3Version D1.90.035 to 50? What's different from vn17?
« Reply #6 on: June 20, 2006, 10:34:37 AM »
Richard:

 Good. So at least we know its a setting of some sort. (Both are the same program..).

 So in Config turn off macropump, andin ports&Pins, make sure All the serial controls are turned off as well as modbus control. (if its on..)

In config/state turn off MacroPump and UDP is its on.

 Were any of those on??

Also, delte the contents of the plugin folder. (If theres anythign in it..)

Thanks
Art

Offline CncBr

*
  •  36 36
    • View Profile
    • CNCBR
Re: Freezing! Mach3Version D1.90.035 to 50? What's different from vn17?
« Reply #7 on: June 20, 2006, 08:24:54 PM »
 ::)

HI FOR ALL,   
Some drives of video AGP ATI that this causing this instability in Mach, this very day I had this problem.

SOLUTION:   
TO USE DRIVER OF OLDER VERSION

THANKS,
Junior
Re: Freezing! Mach3Version D1.90.035 to 50? What's different from vn17?
« Reply #8 on: June 20, 2006, 09:07:02 PM »
Thanks CcnBr - I will check that.

Thanks Art, they were all off and no serial ports/pins configured. But I did see that I wrongly had spindle enabled and set to port 2 (which is disabled). This is different in the turn config which did work.

Removed "JoyStick.dll" from plugins.

Tested OK for 8 mins then just had to go to work....AHH.  So, still don't know if stable.

Any other settings you could suggest I check?

By the way, why does "HiddenScript." come up in the VB macro editor sometimes when Mach3 starts in vn 50? Sometimes this hangs on startup.

Thanks very much for your help - we are making progress!

Richard.

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Freezing! Mach3Version D1.90.035 to 50? What's different from vn17?
« Reply #9 on: June 20, 2006, 10:22:10 PM »
Hi Richard:

  Cant think of anythign else. Check your initialisation string, does it call a macro? There may be some illegal character in it or something.

Let me know what happens on stability..

Art