Hello Guest it is October 21, 2019, 05:07:28 PM

Author Topic: Tool change  (Read 5257 times)

0 Members and 1 Guest are viewing this topic.

Tool change
« on: December 15, 2005, 02:05:02 AM »
Hi. The macro tool change doesn't correctly work. In the old version the function M06 positioned the axle Z to the suitable measure in tool change location. Which is the problem? Mach3 version 1.83.032. Regards Giordano
« Last Edit: December 15, 2005, 02:08:37 AM by giordano »
Re: Tool change
« Reply #1 on: December 15, 2005, 07:47:10 AM »
Do you have home switches on you machine? If you have home switches I can give you a tool change macro that will fix the problem.

Thank you
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Tool change
« Reply #2 on: December 15, 2005, 08:08:01 AM »
Hi Brian. Yes, I on my machine have 2 home switch for each axle. I have tried to copy the files M6start.m1s and M6End.m1s of the old version in the new version but you don't work. Excuse for my English.  I am Italian.
Giordano.
Re: Tool change
« Reply #3 on: December 15, 2005, 08:31:55 AM »
 Here are the macro's that I run:) I have used the same macro for over 2 years so they are very tested...
Hope that helps
Brian

'M6Start.m1s
  tool = GetSelectedTool()
  x = GetToolChangeStart( 0 )
  y = GetToolChangeStart( 1 )
  z = GetToolChangeStart( 2 )
  a = GetToolChangeStart( 3 )
  b = GetToolChangeStart( 4 )
  c = GetToolChangeStart( 5 )

  Code "G00 G53 Z-.1000"  'Pick the Z Axis up to Machine Cord Z-.1
  SetCurrentTool( tool )



'M6End.m1s
  x = GetToolChangeStart( 0 )
  y = GetToolChangeStart( 1 )
  z = GetToolChangeStart( 2 )
  a = GetToolChangeStart( 3 )
  b = GetToolChangeStart( 4 )
  c = GetToolChangeStart( 5 )

Code "G00 G53 Z-.1000" 'Pick the Z Axis back up to Machine Cord Z-.1 if it had been moved

Code "G00 X"&x&" Y"&y  'Move the tool back to where the tool change was activated if it has been moved

Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Tool change
« Reply #4 on: December 15, 2005, 11:10:06 AM »
I am sorry, but don't work.
Giordano
Re: Tool change
« Reply #5 on: December 15, 2005, 01:59:35 PM »
How did it not work?? Did you get an error?

Thank you
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Tool change
« Reply #6 on: December 16, 2005, 08:17:47 AM »
Hi Brian. You look the file attachment.