Hello Guest it is May 20, 2019, 07:09:04 PM

Author Topic: pwm base  (Read 2826 times)

0 Members and 1 Guest are viewing this topic.

pwm base
« on: October 04, 2008, 11:22:14 PM »
The manufacturer of our router table suggests that the pwm base be set at 7.  We are unable to alter this setting and the default setting of 5 will not allow itself to be altered.  Is there another place to alter this setting other than under ports and pins spindle setup?

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: pwm base
« Reply #1 on: October 05, 2008, 02:07:44 AM »
Never used PWM myself but I have just had a look and was able to set mine to what I wanted. What version of Mach are you using? Is the Base Frequency box greyed out that you are unable to change it?

Hood
Re: pwm base
« Reply #2 on: October 05, 2008, 10:22:38 AM »
The PWM is greyed out, and I am not quite sure what it does.  Vortech shows this as a setting, if it is of no consequence then I won't let it bother me at this point. As for what version I am using, it is 3.041. 

I appreciate your response, thanks

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: pwm base
« Reply #3 on: October 05, 2008, 10:44:32 AM »
It is not greyed out here so sounds like you may have another setting that disables it, can you attach your xml and I will see if I can figure whats wrong. As I said I have never used PWM so cant give you an answer off the top of my head but may see something in your xml.

Hood
Re: pwm base
« Reply #4 on: October 05, 2008, 10:50:14 AM »
I am not at the machine right now but will be there later this evening.  I will attach a file if i haven't had any sucess.  Thanks
Re: pwm base
« Reply #5 on: October 05, 2008, 01:26:09 PM »
There is a check-box on the spindle setup dialog to enable PWM mode (labelled "PWM Control").  The default is STEP/DIR mode.  If that check box is not checked, then PWM Base is disabled as well.

Regards,
Ray L.
Regards,
Ray L.