Hello Guest it is July 18, 2019, 10:24:41 PM

Author Topic: Setup help much abliged!  (Read 5278 times)

0 Members and 1 Guest are viewing this topic.

Re: Setup help much abliged!
« Reply #10 on: September 24, 2008, 07:29:04 PM »
I'm also curious why my velocity seems to be capped as a function of steps/unit I used to not be able to go above 150. Now I can't go above 147.13431
« Last Edit: September 24, 2008, 07:34:00 PM by Thorpydo »
Re: Setup help much abliged!
« Reply #11 on: September 24, 2008, 07:50:53 PM »
Upon further inspection it looks like all three axis are almost there. . . 995 tho on x and 996 tho on y and z. Still not sure what the deal is.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Setup help much abliged!
« Reply #12 on: September 25, 2008, 06:42:17 AM »
Try over a greater distance (2 inch) and see if the error doubles

Hood
Re: Setup help much abliged!
« Reply #13 on: September 25, 2008, 11:25:48 AM »
I only have 1" indicators... but I do have a couple of them. I think I might be able to put one on each side and get 2". Or I could compare .5" to 1".

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Setup help much abliged!
« Reply #14 on: September 25, 2008, 04:13:44 PM »
Th greater the distance you can measure the best chance you have of getting things accurate, however  going smaller may give you an indication of whether the error seems to be cumulative.

Hood
Re: Setup help much abliged!
« Reply #15 on: September 25, 2008, 10:25:56 PM »
After playing around with the machine more tonight, I've definitely noticed a correlation. The more you move the axis the more it is off. I've experimented in both + x and - x. Maybe the math is off somewhere or I am supplying the wrong information. . .

5mm pitch on the ball screws, evidence here (deluxe kit):
http://www.cncfusion.com/smallmill1.html

I think the 200 steps/rev on the steppers is typical. I bought Nema 23's 370 from novakon.

Steppers are directly attached to the ball screws.

Gecko drives should be 10 microstepping.

25.4mm to an inch. I thought this was exact but maybe some units are left off?

I suppose I could try setting the mill up in mm and see how it reacts then. I can still use imperial from the DRO by switching the units with the gcode, right?
Re: Setup help much abliged!
« Reply #16 on: September 25, 2008, 10:50:14 PM »
Tried the units in metric with the same results.

I then played with the steps per inch and it seems to be 10182 gives me 1.000"

22 more steps then calculated. Not sure what's wrong but I've verified it using 2 indicators at the same time. . .