Hello Guest it is September 15, 2019, 02:57:38 PM

Author Topic: Noob, needs help, motors turn one way.  (Read 4765 times)

0 Members and 1 Guest are viewing this topic.

Offline Mogal

*
  •  76 76
    • View Profile
Noob, needs help, motors turn one way.
« on: September 12, 2008, 08:33:28 PM »
Hey all, a new build here, I purchased this Keling setup.
I just got it running with the PC last night... Stupid Vista! Now running XP again... LOL anyways...

I only have the demo of Mach3(for now) but having a couple config issues with it. (maybe hardware?)

The problem is the direction the motors turn...
'X' turns one way only(clockwise)
'Y' turns one way only(counter-clockwise), only when Sherline 1/2 pulse mode is checked. Uncheck shirline, turns both ways just fine.
'Z' turns both directions properly at all times.

I have configured Mach3 exactly as the Keling Mach3 Doc

SIDE NOTE: after power has been on ~20 mins or so, Z stepper motor isĀ  warmer then X or Y.

-----

I have all 3 steppers set to 1/8 step, and currently set to 2.1Amps.

As for voltages, I get the following.
-All Com pins constant at 5v

Pin #2 (x axis)
-Powered no movement, 5v
-direction command sent, drops to 3v

Pin #3 (x axis)
- 4.3v at all times - idle, either direction

Pin #4 (Y axis)
- Same as pin #2

Pin #5 (Y axis)
Stays at 0v until command given, then jumps to 2.2v during command, and return to 0v at release of command.

NOTE: The 'Y' axis runs correctly ONLY when the shirline 1/2 us UNCHECKED
- recheck shirline and 'Y' axis acts up again?
- So unchecking shirline 1/2, yeilds the results of pin #7

Pin #6
Same as pin #2

Pin #7
Down command gives a voltage of 0v
Up command gives a voltage of 5v
- voltage stays at last command given.

-----

With the the 'Y' axis working/not working with the shirline 1/2 checked or not has me a little confused as to if its software, or hardware.

Suggestions? Thanks!
Chris

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Noob, needs help, motors turn one way.
« Reply #1 on: September 12, 2008, 08:38:08 PM »
Why are you using Sherline mode? If your drives require a wider pulse then try setting it at 6 in Motor tuning. Sherline mode makes the pulse a lot wider than that and is probably what is causing you problems.
Hood

Offline Mogal

*
  •  76 76
    • View Profile
Re: Noob, needs help, motors turn one way.
« Reply #2 on: September 12, 2008, 09:56:17 PM »
I am using the sherline command because that what the documents have asked for...
I have unchecked the sherline, and changed the step pulse to 6 like you asked.
Z and Y work correctly, but X still turns clockwise only.

Anything else I might try?

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Noob, needs help, motors turn one way.
« Reply #3 on: September 12, 2008, 09:59:28 PM »
Check your direction pin is set correctly and also that the wire is not loose. Can you post a link to the docs as the one you have above doesnt seem to work.
Hood

Offline Mogal

*
  •  76 76
    • View Profile
Re: Noob, needs help, motors turn one way.
« Reply #4 on: September 12, 2008, 10:03:35 PM »

Offline Mogal

*
  •  76 76
    • View Profile
Re: Noob, needs help, motors turn one way.
« Reply #5 on: September 12, 2008, 10:09:53 PM »
Just did a voltage test again...

Pins 5 and 7 corrisponds with the 0v or 5v depending on the direction given, but pin 3 gives a constant 4.3v no matter what....

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Noob, needs help, motors turn one way.
« Reply #6 on: September 12, 2008, 10:13:06 PM »
sounds like you either dont have it configured properly in Mach or your port is bad, think most likley the former. If you attach your xml I will have a look for you but its 3:20 am here so I wont be awake for much longer.
Hood

Offline Mogal

*
  •  76 76
    • View Profile
Re: Noob, needs help, motors turn one way.
« Reply #7 on: September 12, 2008, 10:18:00 PM »
I hope this is the XML your looking for.
Sorry for the Noob-ness LOL

And thank you VERY much for the help.

Chris

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Noob, needs help, motors turn one way.
« Reply #8 on: September 12, 2008, 10:29:19 PM »
XML looks fine, you still have sherline checked but I do see the docs recommend it, not sure why as I used very similar drives on a coilwinder I made and just had the pulsewidth at 3. 
Ok looks like you may have a bad pin in the port, can you swap a pin from another drive configure it to that and see if it works. If you have a spare output pin you could use that and configure it for the direction pin.
 Gotta get some sleep so hopefully you will be sorted by tomorrow.
Hood

Offline Mogal

*
  •  76 76
    • View Profile
Re: Noob, needs help, motors turn one way.
« Reply #9 on: September 12, 2008, 10:41:54 PM »
Thanks, will try anouther output.

Wow, great stuff Hood!
I just moved the motor output (pins 2-3) to pins 8 and nine, set them in Mach3 and walla! its working properly now!!
All axis are turning like they should.

So it seems it is a defective board...

Thanks Hood! Sleep tight tonight, yea did good! LOL

Cheers,
Chris