Hello Guest it is December 06, 2019, 03:49:15 AM

Author Topic: Setup Problems  (Read 3988 times)

0 Members and 1 Guest are viewing this topic.

Setup Problems
« on: August 23, 2008, 02:06:41 AM »
I have went through everything in the setup videos and for mach3 and read on the forums, tried many motor tuning as suggested in the forums and I am still having a problem. The issue is that after setup, when I enter in shuttle mode to go .100 that's fine in +/- of 0.000. but any thing past that, It starts adding .002 to .004 for every .100!? my .001 inch moves are only about .0001 and anything over .100 well Who Knows(one of those Mind Of It's Own things). I have the nema34 steppers 425, xylotex board. Everything I run in mach3 without the steppers on does just fine . good example, I bored a hole a depth of 1.23, Nope it thought 1.85 is where it wanted to go and Did. Any help on this issue would of great thanks.
 
   Thanks Sam
Re: Setup Problems
« Reply #1 on: August 23, 2008, 02:13:32 AM »
Double check your "Steps Per" setting in the motor tuning window.
Maybe run the auto utility on the settings page. I think that's where it is. Dont have Mach right now, on antique laptop.
RC
Re: Setup Problems
« Reply #2 on: September 17, 2008, 06:27:46 PM »
Sounds like your "Steps per inch"  needs further adjustment.

I went to 1" increments to set motor tuning. This made it easy to set steps per inch.

My baseline was 20,000 steps per inch. Dividing by 1000 mils/inch translates to 20 steps per mil.

You state you are getting 1.020 when you command a move of 1.000. Look at your "Steps Per" setting. Divide by 1000 to give your steps per mil.

Place carriage with the carriage in the middle of travel range. Remove backlash. enter G0 X1. Record how far it actually moved. Enter X1 again and Record actual distance moved. Repeat this a total of 5 times. Average the actual distances.

Multiply the average actual distance greater than 1.000 by your steps per mil and subtract it from the "steps per" in the motor tuning window. Run the test again with the new steps per, and repeat adjusting until you get an acceptable number.

Repeat for each axis.
« Last Edit: September 17, 2008, 06:30:13 PM by Cincinnati »
Re: Setup Problems
« Reply #3 on: December 12, 2008, 03:39:47 AM »
Hi,

I set mine up near enough then used the auto calibration on the diagnostics page. I clamped a digital caliper onto the axis i was testing. Once the auto had got as close as it could and was alternating each side of the movement I went back to manual setting in the motor tuning section and made very small changes until on the auto test run I was getting the correct movement. To avoid any automatic update just leave the units moved result box at zero.Now on a move of 25mm I get 24.99 to 25.01 which is probably near enough.


Regards

Julian.