Hello Guest it is May 20, 2019, 05:23:05 PM

Author Topic: Rotary A Axis limits disable  (Read 3570 times)

0 Members and 1 Guest are viewing this topic.

Offline Sage

*
  •  365 365
    • View Profile
Rotary A Axis limits disable
« on: August 21, 2008, 10:24:38 AM »
I have a rotary table on the A-axis. What settings do I need to put and where to disable the limits. I searched on the subject and someone mentioned a check box to enable / disable the A-Axis limits. They didn't say where it was. I don't see it.


Sage

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Rotary A Axis limits disable
« Reply #1 on: August 21, 2008, 11:10:49 AM »
All limits are set up in Ports and Pins, Inputs, you can enable or disable limits for each axis.
Hood

Offline Sage

*
  •  365 365
    • View Profile
Re: Rotary A Axis limits disable
« Reply #2 on: August 21, 2008, 11:30:49 AM »
Excellent. Thanks. I guess I missed that.

Now the answer will be out ther for the next person searching.

Sage

Offline Sage

*
  •  365 365
    • View Profile
Re: Rotary A Axis limits disable
« Reply #3 on: August 21, 2008, 08:08:09 PM »
Not being at my machine when I replied before, I now realize what I really meant to ask.
How do I turn off the SOFT limits just for the A axis. I've tried all combinations 0 and 360 + and - and it seems to try to obey them all or complains that it won't move the A-axis at all because the soft limits are surpassed.
 I want to keep the other axis soft limits on for safety but I need the A-axis to go from 0 to 360 to cut some gears.

Sage

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Rotary A Axis limits disable
« Reply #4 on: August 21, 2008, 08:12:48 PM »
Go to homing and limits and put in a huge positive and negative number for the A and see if that works. There is probably another way but I have never had an A axis so have never had the need to look.
Hood

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Rotary A Axis limits disable
« Reply #5 on: August 21, 2008, 08:13:59 PM »
OK just had a look, Geeral config page, option for softlimits on rotational axis

Hood

Offline Sage

*
  •  365 365
    • View Profile
Re: Rotary A Axis limits disable
« Reply #6 on: August 21, 2008, 08:51:02 PM »
Darn. You guys are good. I must have looked at that page a dozen times. I even checked the box above it to have 360deg rollover.

I also have to hand it to Artsoft for thinking of everything too.

What I also found interesting when I was trying to fool it was that it would accept 9999 as you suggested and it also worked but it would not accept 370deg with the automatic rollover at 360 turned on. My thinking was that it should never get to 370 due to rollover so it should never limit out. Alas it didn't work.

So now the question becomes how does one have two rotational axis, one with limits and one without? I guess I'll worry about that when the time comes.

Thanks again.
Sage

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Rotary A Axis limits disable
« Reply #7 on: August 22, 2008, 02:35:47 AM »
9999 in a entry box usually sets it to zero, also -1 I think.
Are you meaning actually have two rotational axis at the same time or are you meaning sometimes you want limits others you dont? Also are you meaning limits or are you meaning softlimits ;)
 If its the same rotational axis that you would sometimes like limits and others not then I suppose you would just have to change that setting on General config.
Hood

Offline Sage

*
  •  365 365
    • View Profile
Re: Rotary A Axis limits disable
« Reply #8 on: August 22, 2008, 08:14:11 AM »
Yes, sorry I was always speaking about soft limits. I was getting lazy.
Yes. I was referring to having two rotary axis at the same time. With only one checkbox in the software to disable soft limits for all rotational axis it could be a problem (for someone. Wont be me any time soon). A suggestion would be to have a separate checkbox for each axis capable of rotary action like for the hardware limits (in ports and pins / inputs)

Thanks for your help. Working fine now.


Sage