Hello Guest it is January 28, 2020, 01:53:51 PM

Author Topic: Strange issue since installing SS  (Read 8465 times)

0 Members and 1 Guest are viewing this topic.

Re: Strange issue since installing SS
« Reply #10 on: August 21, 2008, 10:28:03 PM »
here is my xml , I forgot all about the backup  , I am sure its something simple I have screwed up .

Re: Strange issue since installing SS
« Reply #11 on: August 22, 2008, 09:57:52 AM »
I replaced the xml with my backup and the error message doesnt come up and the red light is lit , gotta back that xml up in multiple locations.

Found my estop interferance problem , I have/had a fuse thats making intermitent contact in the fuse holder , I plugged the power supply in before turning on the lights this morning and saw a small blue spark , which explains why it was working fine a few days ago when I started the computer after the power supply was plugged in .

Thanks for all the great help and advice , more stupid questions to follow :D
Re: Strange issue since installing SS
« Reply #12 on: August 22, 2008, 10:58:02 AM »
do u guys recommend placing SS in an metallic box.which could help in controlling the noise issue.
iam planning to shift to AC induction motor for my spindle(which need VFD),which of course cause lot of noise.
Re: Strange issue since installing SS
« Reply #13 on: August 22, 2008, 02:43:32 PM »
Im not sure my VFD is in the same cabinet with the drives, SS and two breakout boards , I havent been able to get it to power up aince the SS instal but I will before the day is over.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Strange issue since installing SS
« Reply #14 on: August 22, 2008, 04:37:33 PM »
I have my VFD and SS in the same space and dont have a problem now, at first I occasionally got E-Stops in the SS (not shown in Mach, just in SS itself) Since Greg enabled the digital filtering I have not had a problem, I have it set to 1.43 which is the lowest available and its fine.
Hood
Re: Strange issue since installing SS
« Reply #15 on: August 22, 2008, 05:33:29 PM »
Very happy with smooth stepper , I have been able to dial my full size bridgeport in at 4 times the original transit speeds . I cant wait to try the 40 amp 200v granite drives with my original 177vdc power supply , would love to see rapids in the 300ipm range.

No problems with interferance from the VFD

I have found one little bug that I mentioned in another thread that seems to still be happening.  If I go in and modify the freq on the smooth stepper config page it throws off the distance my x axis moves , the first time I did it it would add .0035" to the distance the x axis moved from zero. Brett spent a big chunk of one of his mornings stepping me thru setting up a new profile and the problem was resolved. After finely tuning my Geckos today I needed to change the values from 32k to 64k and the problem is back.

Now when I am at x0. and I callout x10. the machine moves to x10.0015 , when I call out x0 the machine moves back to x0.0015 , to get it to move to x0.00 I have to call out x-.0015 , these distances are actual distance traveled as well as displayed on the DRO . The only change made was to the freq on the smooth stepper setup page both times this happened. I am guessing like last time I need to create a new profile to clear this problem.

Not unhappy or complaining , just pointing this out as it might need to be addressed
« Last Edit: August 22, 2008, 06:19:46 PM by panaceabeachbum »
Re: Strange issue since installing SS
« Reply #16 on: August 23, 2008, 06:31:18 PM »
played with this quite a bit today after the power came back on , not sure why but any time I change the x axis freq on the smooth stepper setup page I have to make a new profile .
Re: Strange issue since installing SS
« Reply #17 on: August 23, 2008, 08:58:10 PM »
Brett was kind enough to alert me to this thread.  And thank you Brett for all the time you have spent helping out.  I read through all the posts, and one thing I would like to mention about the red LED is that it needs to be on before the FPGA on the board will program.  There is a signal that is output from the FPGA that says it is ready to be programmed, and this signal drives the red LED.  It needs to clear its internal memory before it is ready, and it needs to wait for all three of its power supplies to be within specification (1.2V, 2.5V, and 3.3V).  It should be within a tenth of a second or so.  In other words, fast.  The blue LED is simply connected to the 5V of the board.  The green LED is the DONE signal from the FPGA.  When it first powers up, the blue and red LEDs should be on steady.  Then it will program once the plugin runs, and the red LED will go out and the green LED will come on.  The only LED of the three that can be turned on or off by the FPGA is the red one.  Once the plugin is talking to the FPGA, it will command it to blink the red LED every time it sends a packet of information.  This happens approximately 10 times per second.

I'm not sure why you are seeing the inaccuracy with the X axis, but I have an idea.  The current plugin can be off by one step at any moment in time, but it will never accumulate errors.  The reason is because I needed to find a way that it would respect setup and hold times for the step signal relative to direction.  In other words, lets say that it just output a step signal at the time it was doing a direction reversal.  To make sure the stepper (or servo) driver's timings were not violated, I had to implement some hysteresis in the step signal.  If it just output the step, then it can't output a step immediately when it changes direction.  It has worked out well, especially for machines that have a high number of steps/unit, because in those systems, one step means very little.  Like I said, it never accumulates error, it just could be off by a step.  Being the perfectionist I am, I am going to remove the hysteresis, yet also provide the necessary delays that I couldn't add before.  I have a solution in mind that will work quite well.  I will implement it soon, after I finish threading and soft limits.

Please let me know if the error you see is more than one step, otherwise this probably explains it.

Thanks,

Greg
Re: Strange issue since installing SS
« Reply #18 on: August 23, 2008, 10:29:29 PM »
Hi Greg , Both times I the problem has developed its been when I change the freq on the SS config page for the X-axis. The first time the error was 70 steps . We generated a new profile and the problem was solved.

This time all I did was changed the freq from 32k to 64k and the error is 20 steps. It didnt affect any  of the other axis either time, although I changed the freq on the y and z axis also both times.

The error only adds .0015 (20 steps) one time.  When I start at x0 and call out x 10 , the machine moves to x10.0015 when I then call out x12. the machine moves to x12.0015 and so on , when I call out x 0 it moves back to x0.0015  .  To get back to x 0 I have to type in x-.0015 .

The other error message developed when I unplugged the USB plug from the SS board. I did try unplugging/replugging a few times as well as rebooting the computer . I powered down the comp and unlugged the SS board over night and havent seen that message again .

I was able to create a new profile this morning and the extra 20 step issue went away so its not really an issue , could very well just be some fluke with my comp etc. I have three lathes waiting on the spindle encoder input to be active so I would say skip this little one off issue and focus  on important stuff/

Thanks Richard
Re: Strange issue since installing SS
« Reply #19 on: August 23, 2008, 11:07:20 PM »
Hi Richard,

Thanks for the detailed reply.  I'll have to give this some thought.  What version of the SS plugin are you using?

I'll take your advice for now and work on threading :-)  But let me know if the problem recurs.  Once you have it running properly, be sure to save the XML so that you can switch back and forth between the two XML files.  If you can reproduce it reliably, then I should be able to do it here too, if you send the XMLs to me.

Thanks,

Greg