Hello Guest it is September 15, 2019, 02:55:40 PM

Author Topic: Version 3.042.003 Ready for testing.  (Read 5993 times)

0 Members and 1 Guest are viewing this topic.

Offline Chaoticone

*
  • *
  •  5,589 5,589
  • Precision Chaos
    • View Profile
Version 3.042.003 Ready for testing.
« on: August 15, 2008, 08:53:39 PM »
Brian just sent me this and I thought I would share it with you. As of this posting it isn't on the downloads page but the link in this thread will get you to it. As allways, anyone testing and giveing constructive feedback is a huge help.

Hello all ,
Sorry about the delay but this was another big step to making the
foundation of Mach3 more stable  :) . There was a section of code for the
Arcs in Mach3 turn that was known to be a bit of trouble and it is now
fixed. This was one of the parts that I was in hopes to fix in about 5
revs but I was seeing some interaction with the Scripting code.

The following problems where fixed:

1.) We now check to see that all Mcodes that where called are finished
before we continue to run the next line of code
2.) All Mcodes are run at the same time that are on the same line... So
if you have an M3 and an Mxx they will start frm right to left and will
be running at the same time. We will need to see if there are any odd
problems with this but from my testing it is working well...
3.) Arcs in Lathe mode where a bit munched.. They should be all set
now... Please tell me if you have a lathe file that will not work
4.)4th axis feedrates are fixed if you change the Z value by moving the
tool.. there was a type that must have been there for many years at this
point!
5.) The Arcs will now flash as the line segments do when you scroll down
over them... This was taken out of one of the revs because it would
contaminate the moves in the buffer to go to the P Port.
6.)Threading Updates for the smooth stepper and so on...

You can get the new rev here:
http://www.artsoftcontrols.com/downloads/Mach3Version3.042.003.exe


Things that could still be a problem,
1.) Stopping some scripts on some computers is still giving me a bit of
trouble... for example if you have more then one script requesting to
stop all the other scripts you will get an error... I have added code
that should stop this but I have one user that can still break it in
testing. So if you break it or get an error I would love to have some
example code to help me find this trouble (It works fine with everything
I give it here).


So what is next!
1.) Cutter comp has made it to the top of the list  :)  And I think it is
about time! I am in hopes that we can clean up a few of the errors that
it has and see if we can make Graham, Terry and John happy with how it
works (All off them equally masters of comp). If they are happy I think
the rest of the world will love it!
2.) Review the code for the G95 in Mill that Terry has been talking about
3.)Feedhold LED/Running LED
4.)Review the 4th Axis CV and feedrate code to be suer there are no
other typos

That is the list that I would like to have done before I make the jump
to 3.043 and I think that will clean up most of the small nagging
troubles that we are seeing  :)  (I will try not to make more as I am
fixing the others  :)   ).

I will be starting the code for this in about a week... I will be at the
IWF show looking at routers and seeing what the latest and greatest is
in the world of Routers. I head out on the 17th and will be back working
on the 23rd. The show starts on the 20th and if you are in the Atlanta
area I would suggest having a look at the show! There will be routers
running at over 3000 IPM  :)  What A BLAST!


Well time to have you guys test and tell me if this rev is ready to make
to the webpage  :)

Thanks
Brian
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Chaoticone

*
  • *
  •  5,589 5,589
  • Precision Chaos
    • View Profile
Re: Version 3.042.003 Ready for testing.
« Reply #1 on: August 16, 2008, 09:40:16 PM »
Updated again. This is the new link.   http://www.machsupport.com/downloads/Mach3Version3.042.004.exe   This is also avaliable on the downloads page.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Version 3.042.003 Ready for testing.
« Reply #2 on: August 17, 2008, 05:39:39 AM »
Brian:

Downloaded and ran 3.042.004 version and had nothing but problems.  Code that ran perfectly in version 3.041 would not run without problems in arcs, etc.  One thing I noticed on the Diagnostics screen is the abs max x, y, z were all out of proportion to the drawing in the code in mill mode.   The figure in the code is 11.5 by 5.5 inches - the Diagnostics screen showed the max to be like 116 (somethings).  Yes, I copied my old xml file into Mach before running the code.  Yes, my native limits were in inches.   I had the same problem with another code.

Had to delete the new version and revert to version 3.041.

I will be glad to download the code if you want to test against it.

Thanks for all the time and work you have devoted to Mach.  In spite of occasionally problems (which have generally been corrected very quickly), I have found the software in Mach and LCAM to be a great tool.

Bob @ BobsShop

Offline docltf

*
  •  353 353
    • View Profile
Re: Version 3.042.003 Ready for testing.
« Reply #3 on: August 17, 2008, 03:28:02 PM »
Brett

what is the prefered way to report to Brian and how to report it.i have found an issue and was wondering how to package the info for him.

thanks bill

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Version 3.042.003 Ready for testing.
« Reply #4 on: August 17, 2008, 03:37:42 PM »
Bill,
 Brian is away for a week to a show so probably best to post here and no doubt he will be pointed to here when he returns. This version has had a lot of changes done to the way it interprets macros  amongst other things and is strictly a test version so bugs will be found. A lot of people have been testing this version over the last few weeks and lots of problems have been found and rectified but there will be lots more found I am sure as the amount of testers increase. I am thinking Brian will have as much hair as I have when this version reaches release status :D but from what I have seen so far its going to be worth it, lets just hope Brian's wife likes a follically challenged husband ;D
Hood

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Version 3.042.003 Ready for testing.
« Reply #5 on: August 17, 2008, 03:40:34 PM »
Bob
 Did you actually run the code or were the arcs wrong in the toolpath only? Reason I ask is Brian has been working on the toolpath a lot in this version and although I had problems with the toolpath in the lathe it actually cut correctly. Brian got these problems sorted and the arcs and position now show correct for me but sounds like more work is needed.
Hood

Offline docltf

*
  •  353 353
    • View Profile
Re: Version 3.042.003 Ready for testing.
« Reply #6 on: August 17, 2008, 05:50:44 PM »
Hood
i attached the tap file and a copy of my xml. this tap file is 1 of 6 in the set. the other files to the set load and report properly. this file when loaded should report x-range -0.6100 to +0.6100 instead it reports -0.6100 to +0.7846 ... ver 42.004 is looking pretty good but i did not find any hairs in it, Brian must have changed barber's.

bill

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Version 3.042.003 Ready for testing.
« Reply #7 on: August 17, 2008, 05:56:51 PM »
Bill I did notice that on my Lathe today when I was testing out the SS plugin, the z range was something like -89mm which was correct but the +ve was something like 1000mm, should only have been around +200. Mine cut fine but often I use that screen for seeing if I will be within travels otherwise I would have to scroll through the code to find the max and min, so it is a much used feature by me:)
 Will look at yours and see if I see the same.

Hood

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Version 3.042.003 Ready for testing.
« Reply #8 on: August 17, 2008, 06:06:30 PM »
Yes seeing exactly the same, just a reporting error though as the code seems to run fine, I am sure Brian will get that sorted.
Hood

Offline docltf

*
  •  353 353
    • View Profile
Re: Version 3.042.003 Ready for testing.
« Reply #9 on: August 17, 2008, 07:25:46 PM »
Hood

I loaded 42.4 on the office comp to look at it ,did not load it on the mill. i was just looking at a set of files and doing dummy runs. the other 5 files loaded and reported properly on the x-range but that one did not, just thought it was worth reporting. all the stuff i am cutting is still done with 2.02 while waiting for the upgrades. Gary at SS has been steady doing stuff right along with Brain to get all new software done. it will be sweet when it is all done.

bill