Hello Guest it is June 24, 2019, 08:23:08 AM

Author Topic: Visual offset in tool/job display showing  (Read 4220 times)

0 Members and 1 Guest are viewing this topic.

Visual offset in tool/job display showing
« on: June 02, 2006, 05:43:13 AM »
Hi guys,

This is a great source of info and I have learned alot but need help with a problem I am having. I am using Vcarve to generate my G code. After loading my G code into Mach 3 I notice that the graphics and text is displaying in the table and job display window with a definate visual shift. The material dimension outline and work offsets are displaying correctly in the Mach 3 table and job display window but anything else is offset pulling up and to the right. Design is centered in the material in Vcarve and when cutting the actual piece Mach 3 cuts everything centered and true.

Why would text and graphics within the material be showing a visual offset within the table/job display window if everything cuts fine? I must have a setting set up wrong but have no idea what I need to do to correct this problem.

Any help would be greatly appreciated.

Thanks

Chris 
Re: Visual offset in tool/job display showing
« Reply #1 on: June 02, 2006, 07:00:37 AM »
Chris if you could attach a samle Gcode file and I will see if there is anything in the Gcode file that could shift the file.

Thank you
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Visual offset in tool/job display showing
« Reply #2 on: June 02, 2006, 06:31:25 PM »
Hi Brian,

Thanks for your help. I am attaching a simple file which offsets in my job/table display.

Just to clarify, when loading this file into Mach 3 the material position is shown correctly, all axis are at 0,0,0. It is just the graphic/text that is being offset incorrectly in the table/job display.

When rechecking in Vcarve, the design is centered in center of material. I really appreciate any help you can give.  :)

Chris
Re: Visual offset in tool/job display showing
« Reply #3 on: June 02, 2006, 10:37:45 PM »
Try changing the feedrate of the file to 25IPM... It is Set to 600IPM and that sounds a little fast... You could be out doing your motors...

Hope this helps

Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Visual offset in tool/job display showing
« Reply #4 on: June 03, 2006, 08:29:03 AM »
Brian,

Thanks for your help. I set the feed rate to 25 ipm but still no go. Since we are looking at a static display of table/job window within Mach 3 I am not sure this would have helped. Short of reinstalling both programs I do not know what else to do. There should be no reason why the design is shown not centered in material when loading the code.

I appreciate all your help

Chris
Re: Visual offset in tool/job display showing
« Reply #5 on: June 03, 2006, 09:45:10 AM »
There is a 12inch shift in the X positive direction in your program that you got from Vcarve... I can tell you how to get this to cut where you would like on the table but it looks like a problem in Vcarve (I have never used it). There are other on the forum that use it and they may be able to help.

Thank you
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Visual offset in tool/job display showing
« Reply #6 on: June 03, 2006, 12:52:09 PM »
Brian,

This 12 inch shift sounds about right as to what is showing up in my Mach 3 display. I emailed Tony at Vcarve about this and am sure  we can get this corrected. It may be that I did something within their program since I have not heard of this problem on any of the boards/forums.

Hopefully, I can get others who use this program to input their workaround to this problem. You mentioned you could work around this problem to cut where it should. How would you do this?

Thanks again for your help in troubleshooting my code. Your diligence is truely appreciated.

Chris

Re: Visual offset in tool/job display showing
« Reply #7 on: June 03, 2006, 07:03:29 PM »
Here is your program with a G52 added in... This is a way to shift the Gcode program ;)
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Visual offset in tool/job display showing
« Reply #8 on: June 03, 2006, 08:55:31 PM »
Brian,

Thanks for this fix. It works great.

I found out if multiple cuts are designed on a single piece of material in Vcarve, then loaded in Mach 3 individually (I do not have auto tool changer) then this is where the offsets start to appear. If one tool is used for entire material piece and then loaded into Mach 3, there are no offsets.

Your right, this has something to do with Vcarve and I am sure they will take care of this.

Anyway, thank you very much for your help and that G52 that was added!

Chris