Hello Guest it is August 24, 2019, 10:21:19 AM

Author Topic: Limit Switches working in reverse  (Read 4936 times)

0 Members and 1 Guest are viewing this topic.

Limit Switches working in reverse
« on: July 26, 2008, 09:09:54 AM »
The switches will activate by hand, and the software shows it triggered.  But when I jog the axis to the limitswitch, it will not activate until I reverse the jog direction and clear the limits arm.  What setting do I change to correct.

Screw in Texas----Inivator

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Limit Switches working in reverse
« Reply #1 on: July 26, 2008, 09:18:00 AM »
Please attach your xml.
 Hood
Re: Limit Switches working in reverse
« Reply #2 on: July 26, 2008, 09:40:24 AM »
here it is.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Limit Switches working in reverse
« Reply #3 on: July 26, 2008, 09:48:54 AM »
Dont see anything wrong as such. When you look at the diagnostics page
 are any of the LEDs lit for the Home or limits?
When you press any of the switches do all the LEDs light?
Have you tried pressing all switches to make sure the LEDs light?
Does your homing work? when you press Ref all you z axis should move towards the switch, hit it then reverse a bit and stop, your Y should then do that and lastly your X.

Hood
Re: Limit Switches working in reverse
« Reply #4 on: July 26, 2008, 09:59:01 AM »
When I go to the Dia. page all of the led's a lit.  When I press a limit-s, the leds go out.  When I do a ref all it goes through the switches.

Inivator

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Limit Switches working in reverse
« Reply #5 on: July 26, 2008, 10:28:24 AM »
ok change the active low setting for each limit and home switch in ports and pins
Hood
Re: Limit Switches working in reverse
« Reply #6 on: July 26, 2008, 10:42:44 AM »
Now I have lost all of my settings.  How do I restore my xml. settings

Inivator

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Limit Switches working in reverse
« Reply #7 on: July 26, 2008, 10:47:16 AM »
OK looks like you cut your xml instead of copying it. Go to the copy you made on your desktop and copy and paste it into your Mach3 folder. Now best idea is to leave it the same name so in future upgrades it wont get overwritten by mistake (shouldnt do but any custom macros etc would )
 Now use the Mach3 loader to start Mach and choose Inivator1 from the list.
Change your active low states on all the limits and homes and see if it works.
 If it does then I will tell you how to change the Mach3Mill icon on the desktop to open your new profile.
Hood
Re: Limit Switches working in reverse
« Reply #8 on: July 26, 2008, 10:55:29 AM »
Thanks you again very much Hood, that took care of the problems..  I hope that that is end of my problems and questions.

Have a nice week-end.

Again, many thanks

Inivator

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Limit Switches working in reverse
« Reply #9 on: July 26, 2008, 10:59:16 AM »
OK do you want to open your new profile from the Mach3Mill Icon or are you happy just opening via the Mach3 loader? Or did you change the xml back to Mach3Mill.xml?

Hood