Hello Guest it is October 20, 2019, 03:54:46 PM

Author Topic: Motor tuning wont open in Mach 2.54, plus more  (Read 3366 times)

0 Members and 1 Guest are viewing this topic.

Motor tuning wont open in Mach 2.54, plus more
« on: June 04, 2008, 10:55:31 PM »
Hello all,
I have a version 2.54 on one machine. Toshiba laptop. It runs version 1.83 just fine. I could step the motors using the keyboard, I could step the motors using the screen pendant.
When I opened version 2.54 this evening. I could not run the motor tuning program.  I played around a little still not luck, So I copied an older known working profile to the Mach 3 directory and restarted Mach3. Now I can get the motor tuning program to come up but the motors wont turn. I haven't exhausted all my options yet. But was looking more for some quick insight.
Also what is the latest and greatest stable version running?

Thanks guys
Neil

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Motor tuning wont open in Mach 2.54, plus more
« Reply #1 on: June 05, 2008, 02:52:59 AM »
The latest Lockdown is 2.63 and the one I am using is the Development Ver 3.041

Please attach your xml  and maybe something wrong can be found.
Hood
Re: Motor tuning wont open in Mach 2.54, plus more
« Reply #2 on: June 05, 2008, 07:12:43 AM »
Thank you for the quick reply,
I'll hook my laptop up to the internet later and upload the xml file.

Thanks
Neil
Re: Motor tuning wont open in Mach 2.54, plus more
« Reply #3 on: June 06, 2008, 06:45:06 AM »
Here is my profile file finally, I haven't had the chance to look at in detail yet. So perhaps you can let me know what may be wrong.
Thank you
Neil

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Motor tuning wont open in Mach 2.54, plus more
« Reply #4 on: June 06, 2008, 02:10:19 PM »
Just had a quick look and the first thing I see is you have the Jog Control button off, enable that and see if it helps, I will go have another look at your xml and post if I see anything else.
Hood

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Motor tuning wont open in Mach 2.54, plus more
« Reply #5 on: June 06, 2008, 02:12:32 PM »
Also you have the Hotkeys set up for jogging to NonStandard keys, did you mean to do this?

Hood
Re: Motor tuning wont open in Mach 2.54, plus more
« Reply #6 on: June 06, 2008, 04:06:46 PM »
I changed things to using the arrow keys.
Is the Jog control button the one with the  "Ctrl-Alt-J" option?

I haven't tried it yet.
But I did reinstall, and notice some ir-rational behavior coming from the laptop before the reinstall.
So this could have ben what causing my problem. I let you know.

Thank you for your quick replies.

Peace
Neil

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Motor tuning wont open in Mach 2.54, plus more
« Reply #7 on: June 06, 2008, 04:15:23 PM »
Yes thats the Jog Control, it should have a green light surrounding it, if its off you wont be able to Jog with keyboard or even a MPG.
 The keys are not set up as the normal arrow keys on a standard keyboard in your xml but they may well be set up for the arrow keys on a Laptop, as long as you see the DROs moving when you press the keys you know they are set up right for your keyboard.
Hood
« Last Edit: June 06, 2008, 04:52:21 PM by Hood »
Re: Motor tuning wont open in Mach 2.54, plus more
« Reply #8 on: June 06, 2008, 04:37:06 PM »
Thanks Hood,
Originally I had the keys set up for the A-D/W-X keys this was from traditional gaming set up that I was use to.