Hello Guest it is June 26, 2019, 10:56:38 AM

Author Topic: Step Pulse Won't Save  (Read 6156 times)

0 Members and 1 Guest are viewing this topic.

Step Pulse Won't Save
« on: May 28, 2008, 08:21:09 PM »
I just finished converting an Enco tabletop mill to CNC and have gotten the x/y axis working fairly good but I have been unable to save the recommended Step Pulse setting.  I'm using Nema 34 steppers (4 wire type from Homeshopcnc) and Gecko 201s and it's my understanding that the Step Pulse should be set to 2.  When I enter this setting and save it appears to work but when I return to the setup screen the value is 1.  Any feedback would be greatly appreciated.

Best Regards.
Re: Step Pulse Won't Save
« Reply #1 on: May 29, 2008, 05:37:18 PM »
Rich,

OK, I've tried that and a dozen other things but it just won't persist.  The only reason I decided to set it is that I lost some steps when drawing circles at 60ipm.  Was more curious if that would solve the missed steps more than anything.  I'll never need to drive this thing that fast which is a good thing.  When I run it up to 50ipm doing circles it's right on.  I never expected the accuracy I'm getting out of this old thing so I'm pleased.

Thanks again for the feedback.

Best Regards.

Carl
Re: Step Pulse Won't Save
« Reply #2 on: June 02, 2008, 02:27:07 AM »
Hi Carl,

I to are having the same problems and are specifically loosing steps on the A axis and I cannot change the step pulses, they are currently at zero and even if I do a restart they return to zero. I'm using a Grex also .

My Kernel speed is 100kHz and in the Grex config I have selected 32kHs for all the axiii. If I select higher settings in the Grex the max vel and acc decreases so I have left them as is.

Axis     Step/unit       Vel             Accell
X          50.5102       15000        1250     Servo with a G320
y           39.2857       15000        1500    Stepper with a G203
A          5.55555555   15000        1500    Stepper with  G203

My X and Y axis do not loose steps only my A. I have reduce feed rates to 5000mm/min and gone as high as 15000mm/min. The A axis looses steps to the tune of 5-10 degs when I have the knife removed meaning no load.

This is geting frustratiing. May be the cause is the Grex, but like your post says I wished to adjust these pulse setings and they do not change.

Thought anyone??
Jason

« Last Edit: June 02, 2008, 02:45:49 AM by XLR84x4 »

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Step Pulse Won't Save
« Reply #3 on: June 02, 2008, 03:58:34 AM »
If you are talking about the Step Pulse settings on the Motor Tuning window -

1. You must have the same settings for all axis - although the step can be different to the dir.
2. You must "change" both windows (you need not actually change them, but you need to highlight the window and type in the value you want to keep on BOTH step and dir windows.
3. The "Save Axis settings button" should now be highlighted. Click this and your settings will be saved.
Not me driving the engine - I'm better looking.
Re: Step Pulse Won't Save
« Reply #4 on: June 02, 2008, 06:00:51 AM »
Thanks for the quick response.

Yes I have tried what you have suggested and still no change. It keep resetting to zero. This may have something to do with the Grex???


Jason

Online Chaoticone

*
  • *
  •  5,514 5,514
  • Precision Chaos
    • View Profile
Re: Step Pulse Won't Save
« Reply #5 on: June 02, 2008, 09:06:44 AM »
Jason, I can't remember for sure but I think if using the G100 those aren't setable. Been a long time since I had mine hooked up.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Step Pulse Won't Save
« Reply #6 on: June 03, 2008, 12:51:22 AM »
Thanks Brett,

I did find a short reference to it being set to 0 in the set guide.

The Grex is starting to frustrate me with it's lack of ability to deal with lots of short steps in the Gcode and also the fact tha I can only get my machine to run smooth with feed rates of 2000mm/min. I am also convinced that my A axis loosing it's setps over a large file size is also due to the Grex.

Thanks again for your help

Jason
Re: Step Pulse Won't Save
« Reply #7 on: June 08, 2008, 11:00:36 PM »
I have noticed the same issue with the step pulse value, if you enter the value you want , choose save setting and then close the motor tuning dialouge box it will save your setting but each time you open the motor tuning dialouge box that value will drop by one . I have it set at 11  and each time I open motor tuning it drops by one to 10 , 9 , 8 and so on , you just need to make sure you type in the value you want and click save axis setting every time you open motor tuning.

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Step Pulse Won't Save
« Reply #8 on: June 09, 2008, 02:07:44 AM »
How far does it drop if you keep going in without resetting it?
Hood
Re: Step Pulse Won't Save
« Reply #9 on: June 10, 2008, 11:29:39 AM »
it keeps dropping until it hits 2 on the machine I use daily