Hello Guest it is October 17, 2019, 07:10:50 AM

Author Topic: Hot stepper Motor  (Read 7895 times)

0 Members and 1 Guest are viewing this topic.

Hot stepper Motor
« on: May 03, 2008, 01:03:44 AM »
I have a Vextra PV264-02BA on a A axis to rotate a tangential knife using the tangential control feature in Mach3 and 2.5D to control the Z axis. I have fitted a thrust bearing between the cutter and the stepper so that when the z axis is lowered into the cutting postion it does not put any axial load on the stepper.

My problem is that the stepper is hot to touch even when idle. An when I run a large file the A axis looses steps and ends up dragging the knife around. When in tangential mode the system runs in exact stop meaning that the A axis has to complete the move prior to the X-Y axis moving. This is the limitation of Mach3 tangential control

I have lowered my motor tuning to 5000m/min with accel of 800m/s/s with units set at 5.555555555 and it stil looses steps on the A. I have even run the gcode with out the knife attached ie cutting air and it still looses steps. We are talking 2-8 deg at the end of the program cycle. Some times I have to stop the program re-reference the A axis to stop the problem of the knie getting dragged around the table

THe stepper is wired bipolar to a gecko and I have limited the current to 2A with a voltage of 56VDC. I did have a cheapy stepper doing the same thing that I replaced with the Vextra

Any thoughts on the hot stepper problems.


Thanks
Jason

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Hot stepper Motor
« Reply #1 on: May 03, 2008, 04:18:40 AM »
I looked up the motor on the web, and the PV series seem to be 2.8amp @ 24 volt.

It is normal to drive a stepper motor at 4 times (or more) of the rated voltage. You are only using barely twice the voltage. The problem is at speed (you do not say what speed your motor is turning but it doesn't really matter) - a lack of forward voltage does not allow the current time to build up and produce the power, before the driver turns off and applies the voltage to the next winding.

You are therefore producing some power, but this is wasted - and waste power turns to heat.

You may improve the situation by cutting out the incremental steps from the Gecko - if you can, but really, if you are l;imited to a 56 volt supply, your motor rating wants to be down about the 12 volt mark. My Gecko goes up to 7 amps, so a motor rating at lower voltage, but more current would, I think, do the trick.

You say you had a cheepy on the axis - - how did that perform.
Not me driving the engine - I'm better looking.

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Hot stepper Motor
« Reply #2 on: May 04, 2008, 06:01:27 AM »
There are a variety of factors that can lead to excessive motor heating. Of course at the moment we don't know whether yours is excessive but anyway - considering the quick wins first....

Your motor appears to be a 6-wire 2Amp 2.9V 1.46 Ohm (unipolar rating) motor.

What follows depends on how you have it wired.

IF you have it half-winding connected then your PS voltage of 56 volts is giving an overdrive ration of 19.3:1 which is actually quite high.

Over voltage maintains torque at speed which is not perhaps of primary importance for a tangential knife rotator. The downside of high overdrive is increased motor heating - so this may be one of your problems. Particularly when you consider that a knife control spends a lot of time stationary (holding) - like a Z axis does in 2 or 2.5 D in use. A popular myth is that the current in a stationary (holding) stepper is low, zero or negligable. In fact that's when it's at its highest!

I'm guessing you do indeed have it wired thus because you've set your gecko to 2Amps.

IF on the other hand you connect it full-winding (series) you will have the following rated values for your motor.

1.4 Amps, 4.1 Volts, 2.92 Ohms.

In this case you should current limit your gecko to the 1.4Amps. However at the same 56 Volts of your PS, you'll reduce the voltage overdrive ratio to 13.6:1. Still perhaps a little high for your knife rotator but better than before. This should reduce heating. Please note that heating is reduced in this scenario NOT because there is less current in the coils but because there is less voltage overdrive. The heating due to current will be virtually the same in both cases because the electrical power is virtually the same.

Finally - the worst scenario: IF you already have it full-winding connected then your current overdriving (2A instead of 1.4Amps) and this is definitely not what you want. This WILL lead to heating from over-current and is a good way to damage your motor.

Re: Hot stepper Motor
« Reply #3 on: May 04, 2008, 06:49:32 PM »
Thanks guys for the tips.

Yes I have wired it bipolar and set the gecko to limit the current to 2A. The stepper I replaced with the Vextra had no markings and was of similar size. I limited the current to 0.5A and it still got hot and lost steps. That's why I replaced it.

I understand the voltage/torque relationship at speed. Yes as a tangential knife it rarely does one full turn. I am in a postion to hook up and 24V PS and give it a go. Hopefully  this will cure the heating problem. It's the lost steps that is my main concern. I am thinking that I may have to add a home axis type of code and insert i into the .NC file mid script so that the knife does not tear the cutting table and material apart the moment it get's out of alignment

I  could also do with a program that can convert the X-Y code and write an A axis tangential code. This way I can turn tangential control off in Mach3 getting away from the exact stop bug.

What other ays are there of testing the a axis to find out where the steps are lost.

Thanks
Jason

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Hot stepper Motor
« Reply #4 on: May 10, 2008, 03:21:56 PM »
Sorry about the misleading info on the stepper motor - I found the info on the internet - but now I can't go back to it - so Stirling is probably a lot nearer the mark than I.

As to your other question - there isn't really any way to test the axis to find if it is loosing steps. I can write a program to check that the direction of A is correct in relation to X and Y movement which was your other question, but, in the absence of any feedback as to which way the knife is actuall pointing, then any check merely relies on the DRO's of the system - and since these keep accurate position (even is the axis misses steps) that is not much good - it would always say it is correct.

I have not had any experience of tangential control so cannot comment on absolute stop - v - continuous

I personally would get a bigger motor, or gear down the one you have got. The Gecko drive - if it is like mine - will take a substatially larger motor. Mine are eight wire, 2.5amp per segment, at 7.5v and give 220 Ncm - and they work well and at £23 are cheap. You could probably run them with your 56 v supply.

I cannot get my head ropund your speed figures, however - you are quoting 5000 m (metres)/min - do you mean mm (millimeters). If you also have this acceleration and speed on your knife - IS IT NECESSARY. The knife, at best will only be moving a short time and only moving a few degrees, I would seriously cut down the speed of the knife rotation - you don't need it, and this is always one of the main reasons for missing steps. I have managed to coax 40 ins per minute out of my motors, with Geckos - but I have cut this to 20 ins per minute in deference to accuracy over speed.

The time you would loose by cutting your knife rotational speed by half would be minimal, but might just give you the accuracy you are looking for.
Not me driving the engine - I'm better looking.
Re: Hot stepper Motor
« Reply #5 on: May 11, 2008, 07:42:14 PM »
Thanks for the information.

Regarding the feeds and speeds, I do wish to run them at 5000m/min and higher if possible

To give you a better understanding of where I'm at and a big thank you to all the moderators that have gotten me this far with my build.

I'm using the cutting table to cut  a velour material similar to the auto trimmers hood lining and seat inserts using standard preprogrammed nested patterns. I use Rhino to create iges files and Mastercam for the tool path.
The shapes donot have to be super acccurate and I have my linerisation set to 0.5mm. Its not about the accuracy it's all about the speed. However the A axis has to be accurate or the knife gets dragged around the table dragging the material with it.

With the tangential control in Mach3 the A axis position is configred within Mach3 and the combination of this is that A axis runs in exact stop mode. Not really a problem until you turn up the feed rate and then it becomes very jerky.
On previous advice from the great moderators I have got myself a optical switch to home the A axis. (I have yet to install this) this will help with accurate referenceing at the click of a button. In the past I have been do a visual alignment of the A axis

So the plan is to find a balance of speed verses jerky verses lost steps. I have a GREX as my BOB, but after do a lot of reading I may seem that the clock speed my not be able to handle the feeds I wish to run at and that a Smooth Stepper may be a better bet.

Regarding the A axis stepper. I thought that voltage would be it's friend. It does not have a lot of load. I have a pneumatic actuator that drives the z axis and this is set to 20Kpa and I have a spring to help the z retract. The bead is made from HDPE to assist the cutting blade from bluntning.

So I will give my 24V PS a try on the A stepper and I can also wire this unipolar for a test also.

Any other advice appreciated

Regards
Jason

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Hot stepper Motor
« Reply #6 on: May 12, 2008, 03:52:29 AM »
That is faster than Eurostar!!!

Now I appreciate your problems -

Unfortunately you will not get rid of the jerky movement using exact stop - because that is what it is - all axis simultaneously stop, and then start again on their new path. Quite clearly it will get worse with fast speed and quick acceleration.This - coupled with the speed (and therefore the acceleration) might be the reason for your loss of steps on the cutter. I think you are saying the BED is made from some material to stop the cutter blunting too quickly. Is it soft - does the cutter dig into it slightly. I was wondering if this was the problem. Although only lightly loaded when cutting ( and I have no idea what shape this is ), the strain of trying to turn shall we say "left" when the two axis are pulling you and accelerating to the left must be quite high. The force on the knife is to the right.

There are probably limitations to the Mach3 tangential control - I have no idea about it at all - and maybe someone might tell us. However, it seems to me that the turn of the knife should be BEFORE you then accelerate the other axis, so the knife is correctly lined up at the start of movement. This would mean the A command is on a seperate line before the XY command (otherwise all three happen simultaneously). It may be that tangential control does that - I don't know.

Are you limited to that type of knife - at those speeds a pizza wheel type cutter comes to my mind, -  and if this were mounted slightly behind the Z axis (with the pivot on the Z axis) then it would have a "following" action instead of having to steer itself (rather like a castor action) . Mounting the knife behind the Z axis would, on reflection work for all types of knife and reduce the negative turning force on the blade.

The alternative to Absolute stop is Constant Velocity - but here the next line is read into Mach and the deceleration of the last line is blended into the acceleration of the next line (which is quite easy actually becasue the resultant change of direction is merely an alteration in the speeds of the axis).

How many lines of code are we looking at to produce this shape - are there complex curves in it . I was thinking of how to incorporate the A axis command in the GCode.
Not me driving the engine - I'm better looking.