Hello Guest it is July 17, 2019, 09:37:17 AM

Author Topic: problems with mach3, showing only partial programs/gcode  (Read 3850 times)

0 Members and 1 Guest are viewing this topic.

problems with mach3, showing only partial programs/gcode
« on: April 20, 2008, 09:17:40 PM »
Had this problem before, never really rectified it.. only way I have found to fix it is by reinstalling and resetting everything. It's a pain and I would rather get the source of the issue. I included a screen shot below to give an example. I noticed it first by looking at the geometry in the upper right hand corner, the toolpath screen. It appeared to only display partial or even just a fragment of the actual program. Running it confirmed that, having stopped precisely where that toolpath stops. There's more gcode below but for some reason mach3 goes all buggy and doesn't go any further or show any hope of going further. Also, this happens with multiple files, every one the same, I've tried at least 10  to no avail. Any suggestions? Am I doing something wrong? Maybe the download I have is corrupted? But i have used fresh copies in the past,it just happens randomly one day when I open it up. Thanks!

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: problems with mach3, showing only partial programs/gcode
« Reply #1 on: April 20, 2008, 10:52:42 PM »
Hi, Brian

Look under Help, About make sure your License is showing up, 500 hundred lines of G-code limit without it. N4970 divided by 10 would be 497 lines of code.

If thats not it use the REPLY button and post the Problem G-code file.

Thanks, Chip
Re: problems with mach3, showing only partial programs/gcode
« Reply #2 on: April 20, 2008, 10:53:21 PM »
Are you runing a registered Copy of Mach?

Sid


Ooops, obviously Chip can type faster than me!  :(
Re: problems with mach3, showing only partial programs/gcode
« Reply #3 on: April 21, 2008, 05:28:44 AM »
Thanks for your help. Problem is not with the gcode as I've run these before, just old ones and multiple gcode files.. I will check and reinstall the license tonight, appreciate the help. And yes last time I checked it was saying it was registered and the license was good. Will double check again though.
Re: problems with mach3, showing only partial programs/gcode
« Reply #4 on: April 25, 2008, 05:17:31 PM »
Sorry to not get back to you right away. I checked and it said demo version, weird not sure how it reverted backwards? Reinstalled license and it loads up gcode fine! Thanks for your help guys.
Re: problems with mach3, showing only partial programs/gcode
« Reply #5 on: March 06, 2009, 01:44:09 PM »
I am having the exact same problem. Woundering if upgrading fixed the problem???? PLEASE LET ME KNOW,

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: problems with mach3, showing only partial programs/gcode
« Reply #6 on: March 06, 2009, 02:00:21 PM »
What fixed his problem was putting his licence file in the Mach3 folder.
Hood
Re: problems with mach3, showing only partial programs/gcode
« Reply #7 on: March 06, 2009, 02:05:43 PM »
Great I guess I will be doing that sometime today then..... You have been a great help Hood.

  Another yanked for the jaws of frustration