Hello Guest it is November 20, 2019, 03:55:51 AM

Author Topic: Mach3 current command interrupting  (Read 3480 times)

0 Members and 1 Guest are viewing this topic.

Mach3 current command interrupting
« on: April 20, 2008, 11:38:36 AM »
Hello,
After starting a Gcode interpreting, the Mach3 accindentally  interrupts current command and starts the next one before finishing the previous.

It happens seldom and on accindental lines of code.

Anybody can help ?

Thanks in advance..

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 current command interrupting
« Reply #1 on: April 20, 2008, 05:22:08 PM »
Hi Gregory,
 Is this the Contraves Drives and motors you are using? If so how are you converting the Step/Dir to analogue +-10V, could be the problem is with the converter. Do you see the DROs in Mach going to the right position?
Hood
Re: Mach3 current command interrupting
« Reply #2 on: April 21, 2008, 12:16:44 PM »
Hi Robin,
Nice to meet you here ! :)

Currently I work with a retrofitted HURCO KMB-1x with Gecko G320 servodrives. My PC is DELL 2.4GHz + RAM 256MB + HD 40GB. I've tested it on old PC 670MHz also, the same result. All unnecessary in WINXP unistalled as advised on Artsof site.

The jogging works fine, single commands via MDI seem to work correctly. But if I load and run a simple program from a file, some of commads are omitted or not finished (for example it makes 30% of circle and jumps to the next command).

The same is in OFFLINE mode !

After ubnormal run the DROs show misplaced coordinates and in toolpath window I can see a modified toolpath.

Re: Mach3 current command interrupting
« Reply #3 on: April 22, 2008, 06:47:14 AM »
Hi,

I think you are facing the same problems as described in the following topic
http://www.machsupport.com/forum/index.php/topic,6369.0.html
Spinnetti and myself have found similar problems
The actual toolpath does not stay on the programmed path (Visual on the screen), and it happens not all the time but occasionally

I dont know what the actual problem is, but after I set the "look ahead" (in the config file) to 1 it did not happen to me anymore (????)

Jan

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 current command interrupting
« Reply #4 on: April 22, 2008, 08:06:35 AM »
Sorry for not getting back sooner Gregory, been a bit hectic with woirk etc.
 Sounds like it copuld be a similar problem to Jan and spinnetti's problem so hopefully setting the lookahead to 1 will help you. 
Think Brian is still trying to find the problem, report back if the lookahead to 1 cures it then maybe it will help Brian find the probl;em.

Hood