Hello Guest it is October 19, 2019, 04:03:48 AM

Author Topic: Preparation Positioning, bug?  (Read 11239 times)

0 Members and 1 Guest are viewing this topic.

Re: Preparation Positioning, bug?
« Reply #10 on: July 17, 2016, 05:17:08 PM »
With Y and A values being random, I have to conclude that "Run From Here" is not to be trusted. I'll stick with doing a rewind and then use "Set Next Line" being careful to pick a starting point that defines X, Y, Z, and A.

Thanks to all that helped me.

Rick

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Preparation Positioning, bug?
« Reply #11 on: July 17, 2016, 05:59:09 PM »
I use RFH almost every day and never a problem. On the Lathe I get Y Axis values but there is no Y Axis on my lathe so I presume that is just a left over from when Mach was Mill only. As you have a mill then you have a Y and I do not know why you see the weird Y value as I never see that on my Mills.
 Do you have any custom macros or macropump?
Are you using the parallel port or an external controller?

If you attach your xml and also the simple code you tested with I will have a look and see if I can find the problem.
Hood
Re: Preparation Positioning, bug?
« Reply #12 on: July 17, 2016, 11:09:02 PM »
Hood,

I have no custom macros or macro pumps. I do use a parallel port. Details of my hardware can be found at http://rick.sparber.org/CNCHW.pdf

Please contact me off list so I can send you the XML and gcode files.

If you do figure this out, I will document what you did so others can benefit.

Thanks!

Rick
rgsparber AT aol DOT com
Re: Preparation Positioning, bug?
« Reply #13 on: July 18, 2016, 08:55:59 PM »
I am running XP in my shop.

Rick
Re: Preparation Positioning, bug?
« Reply #14 on: July 19, 2016, 07:31:15 AM »
Also running mach3 ver 66

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Preparation Positioning, bug?
« Reply #15 on: July 19, 2016, 07:33:21 AM »
XP is not a problem however, as mentioned in my email to you, Ver 066 is.
Hood
Re: Preparation Positioning, bug?
« Reply #16 on: July 19, 2016, 07:53:19 AM »
Yes, I do plan to change that and see what happens. I see discussions about problems with ver 66 but no glowing support for ver 62. I have to wonder what new problems will surface with ver 62. It is all about the devil I know versus the devil I don't know.