Hello Guest it is May 21, 2019, 11:24:24 PM

Author Topic: Mach 3 Pulse Rates per axis  (Read 4422 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 Pulse Rates per axis
« on: April 01, 2008, 07:49:24 AM »
I am currently tuning X/A,Y and Z axis on my router. When I try to drive the steppers of each axis above 8000 pulses per second the motors sound awful. Around 7000 they are smooth.  Is this because Mach3 divides the 25000 pulse rate up between all axes?  So by increasing the pulse rate is it possible to drive each stepper faster than say 7000pps.

Just a thought,

Bruce

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Pulse Rates per axis
« Reply #1 on: April 01, 2008, 08:15:00 AM »
No, Mach can output 25KHz, 35KHz, 45KHz or whatever to each axis. Your problem may be more due to your computer than anything else or could be that its the max of your drive/motor combination, maybe dropping the accell a bit will help..
Hood

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Mach 3 Pulse Rates per axis
« Reply #2 on: April 01, 2008, 09:04:28 AM »
I have a similar problem.

Because of the gearing I need 48,000 pulses per inch, and I cannot reliably drive the main shaft on the lathe faster than 4 inches per minute. As you say above that the motor(s) start to sound awful and they will not run at much above 6 ins per minte. I have fiddled with acceleration - slowing it down so the motor(s) have more time to accelerate, quickening it up in case there is a "sticky" patch they need to get through - all to no avail.

In the end I have put it down to mechanical problems - e.g. the drive shaft does not go through the centre of my table, therefore the pull exerted will be lopsided - my cross slide has a central shaft and I can get up to 6 to 7 reliably on that. In the end it does not make much difference to the work I do, because the lathe is only 2feet long, and most of the work is done around the chuck.

I am going to try some ball screws soon - to get rid of some of the backlash - but it might help the speed.

As Hood said - you might have difficulties with your computer - this you can test by taking a motor off the machine and running it on the workbench. See if you can get above the speeds you are quoting - at least then you will have an idea where the trouble lies.
Not me driving the engine - I'm better looking.
Re: Mach 3 Pulse Rates per axis
« Reply #3 on: April 01, 2008, 09:44:08 AM »
I am a bit short on memory (256Mb) in 1.7G dell computer. I will upgrade to 1Gb of ram when it arrives in the post - Might do the trick.

Hood, you may be right about the steppers being maxed - have not had any experience with what is the norm.

At this stage I can still get XY 7000mm/min and 1000mm/min Z  running smooth.

Bruce

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Pulse Rates per axis
« Reply #4 on: April 01, 2008, 10:32:30 AM »
If its computer problems then look out for the SmoothStepper thats just come on to the market (short supply at the moment)
 This is an external board that plugs into USB and does away with the parallel port, it creates the pulses onboard rather than the comp[uter doing it and can pulse up to 4MHz and its super clean pulses :) Have been using a beta board for a few months and its working great. One of the big benefits is it should allow you to use a computer that wouldnt previously run Mach , laptops etc.  Another benefit of this board is it will let people like myself that have servos with High count encoders get the pulserate we need to get the rapids up to nice speeds.
Hood

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Mach 3 Pulse Rates per axis
« Reply #5 on: April 01, 2008, 12:12:42 PM »
do they make a descending growling sound and subsequently stall?
you say above 8000Hz, how much above that have you tried?
what speed are they doing at 8000Hz in terms of rpm?
what drives are you using?
what is the rated voltage and current (or phase resistance) of your motors?
what is the Vdc and amperage of your power supply?