Hello Guest it is July 19, 2024, 04:39:20 PM

Author Topic: Mach3Turn - 1st 'Beta' release of the SilverBlue Screenset for lathes  (Read 124364 times)

0 Members and 1 Guest are viewing this topic.

Art,

Many thanks. I appreciate the offer.

I'm afraid my search for the code has been in vain. A zillion screensavers but not example code that I can find.

If you wouldnt mind hunting it out some time I would be grateful.

Thanks

Offline ART

*
  • *
  •  1,702 1,702
  • Tough as soggy paper.
Hi Santiniuk:

  Least I can do..

Attached here..

Art
Art,

Many thanks. It's a cool piece of code.

(Some heavy maths in there !)

Regards
Re: Mach3Turn - 1st 'Beta' release of the SilverBlue Screenset for lathes
« Reply #23 on: October 18, 2007, 11:52:53 AM »
I just tried out this screen and it looks VERY cool, but I found a couple of problems.  When you go into the cycle mode where you actually start cutting, the LED's on the far right side are not in the correct place.  There is no Tool Change LED, and the one that is actually beside the Tool Change nameplate is actually connected to the coolant function.  I don't know what it is connected to, but I don't think the LED beside the Coolant nameplate is functional.  At least I have not seen it come on...

Great looking screen though...

..
Norm
Re: Mach3Turn - 1st 'Beta' release of the SilverBlue Screenset for lathes
« Reply #24 on: October 24, 2007, 04:52:16 AM »
Norm,

Apologies for the delay. For some reason any mail from the site gets put in my BT spam filter. Even my Google account has started doing the same  >:( So I don't get the alerts unless I visit and notice.

As far as I can check, the operation of the Silverblue set was the same as the supplied Turn screen.

I'm off work now for a few days so let me install the programs again and take a look. It will be good to blow the cobwebs away and do something 'useful' on these dark, miserable, cold, gloomy, damp, UK nights  ::)

Cheers
Re: Mach3Turn - 1st 'Beta' release of the SilverBlue Screenset for lathes
« Reply #25 on: November 05, 2007, 05:22:52 PM »
I used Screen4 to go in and repair my copy of the screen, but just so you have the information there are three leds that are wrong...  On Page 3, right hand side:

Text  --------->  LED
Tool Change  ------------> Coolant LED
Coolant  ----------------> Front LED
Paused  ---------------> Rear LED

It looks like the leds were just copied from Page 2 to Page 3 with the intention to change their functions but it got missed and the functions remained as they were on Page 2.

..
Norm
Re: Mach3Turn - 1st 'Beta' release of the SilverBlue Screenset for lathes
« Reply #26 on: September 09, 2008, 10:29:51 PM »
I have been using this screenset for about 6 months now and really like it , is there anyway i can easily add an MDI line to the automatic/cycle screen? There is an unused black bar right below the tool path that looks ideal , would save a few steps when i need to type in a tool change command .

Also i notice the arrow keys on my keyboard work fine for jogging the machine when I am in the manual screen but are disabled when on the automatic screen