Hello Guest it is October 18, 2019, 06:09:54 AM

Author Topic: Tool path display  (Read 2861 times)

0 Members and 1 Guest are viewing this topic.

Tool path display
« on: March 18, 2008, 07:36:15 PM »
Hi,

I'm using M3 V2.0.058 on the desk pc and  M3 V2.0.063 on the mill, both do the same thing. . . .

When scrolling down the gcode, I used to get a highlighted section of the tool path that relates to the line of the gcode (OK on an earlier version)
No updating to .63, only the G00 and G01 sections highlight. G02 G03 don't "flash". (The arcs do display OK though)

I have changed the settings in config-toolpaths but all I can do is to change the item colours but not get Mach to show the G02/3 sections highlighted as the code is scrolled
I've searched the forums but cant' find anything on this.

Is there a fix or a setting to re-enable this please?

ATB
Derek.


You can "chop it off" but can't "chop it on"
Re: Tool path display
« Reply #1 on: March 19, 2008, 06:32:32 PM »
Update:-

Loaded up M3 R3.037 and its the same :(  (using the Mach3 mill.xml)

I have a part that is 90% curves and I would like to edit the code to vary the feed at various points, but its difficult to tie up the point in the tool path where I need to change the feed with the exact point in the gcode.

Anyone help?

ATB
Derek.
You can "chop it off" but can't "chop it on"

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Tool path display
« Reply #2 on: March 19, 2008, 07:04:45 PM »
I have just looked at mine and its the same, when I scroll through the code and its at an arc the whole toolpath seems to highlight, not in a different colour but seems to get broader, see pics below.
 I will see what Brian says.
Hood

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Tool path display
« Reply #3 on: March 19, 2008, 07:10:11 PM »
Its fine in turn so just seems to be Mill that its affecting.
Hood

Offline Tef9

*
  •  89 89
    • View Profile
Re: Tool path display
« Reply #4 on: March 20, 2008, 07:36:13 AM »
Thanks, I will give this a go tonight.

Andy

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Tool path display
« Reply #5 on: March 20, 2008, 07:49:31 AM »
Talked to Brian and he said he had to remove this function as it was messing with the toolpath. When he reworks the GL he will be puuting it back in.
Hood
Re: Tool path display
« Reply #6 on: March 20, 2008, 03:26:59 PM »
Hi Hood,

At least it was not me this time ;)
I loaded M3 V1.84 and the arc highlighting is working. So Ill edit on the desk PC and transfer to the mill.
The item is a bit like a gear (all rads) and need to alter the feedrate as I go into the valley and speed up round the tops.

ATB

Derek.
You can "chop it off" but can't "chop it on"