Hello Guest it is October 21, 2019, 05:12:09 PM

Author Topic: Mach 3 limit switch overide  (Read 9381 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 limit switch overide
« on: March 07, 2008, 02:35:53 PM »
I am new to CNC mills and Mach 3 software.  So please bear with me. I have Mach 3 Version R3.036. I can not find the limit switch overide. I am having issues with limit swtichs triggering  impoperly. Addtionaly my home switches wont work 100%. When homing sometimes an axis will not back up after hitting home. I tryed  Mach 2- limit and home worked flawlessly so I am sure there is nothing wrong with the hardware. In Mach 2 there was a limit overide soft - switch but i cannot find it anywhere in Mach 3.
Can anyone give me a hand and direct me to it ?

PS : I did just find and will try the  input debouncing on the " General Logic Configuration" page. Anyone have a sugested settings ?

Thank you for your assistance.

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Mach 3 limit switch overide
« Reply #1 on: March 07, 2008, 03:00:59 PM »
Look on the Mach 3 Settings page. You can set what you like there.

I suggest you have a look at the instructional videos which gives you details on how to set them. They have generally been enhanced on Mach3.

I do not know if you have doubled homing switches with limit switches.  You can do. However make sure the correct pin number is shown on BOTH the limit and the home switch. Mach 3 (if it knows it is going home) turns off the appropriate limit switch, and uses it as a home switch. What you are getting is a failure to do that - it is still acting as a limit.

As far as debounce is concerned, start with a fairly large setting say 200 and see what happens - it connot hurt anything. If everything works at that setting you could try reducing it, which might help with homing accuracy.

 
Not me driving the engine - I'm better looking.
Re: Mach 3 limit switch overide
« Reply #2 on: March 07, 2008, 03:30:31 PM »
Thank you for your help !   I had found  the button, but did not realize it because you cant jog from that page! Thanks! I thought it just did not work.
When running the porgram i had gotten hung up on a limit switch and could not get off it without deacivating the limit switch. My setup is

x++ pin 10
x-  pin 11
x home pin 11

y++ pin 12
y- pin 13
y home pin 13

Z++  pin 15
Z-   none
Z Home pin 15

One other issue I am having is: I have soft limits .3" before the limit / home switchs. trying to stop the occasional false triger.  I had to turn off soft limits to get the thing to go to the limit/home switch . I thought  the software ignored  soft limits when it was told to refrence all home? What am I doing wrong?

On the" Index Debounce "what does it do, what should it be set at ?

I did watch the videos, the screen layouts were diffrent on the setting page- I  must have missed the limit overide button. Lots of stuff to learn. When you are 100% green you sure can miss a lot, even when you are looking at it.

Thanks for all your help,

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 limit switch overide
« Reply #3 on: March 07, 2008, 03:47:18 PM »
Your soft min should be zero, you can then set a slow zone up so that even when travelling at full rapids Mach will have time to slow before hitting the hard stop. The reason it is zero is because the home position in Mach is actuall once the switch has closed again so setting a zero as soft min should never hi your switch.

Hood
Re: Mach 3 limit switch overide
« Reply #4 on: March 07, 2008, 03:49:25 PM »
Hello there pcbmiller,
It ignores the switch as a LIMIT when homing. Soft Limits have to be OFF. WRONG....Can be ON
Debounce is explained below.
RC

AND YES.....Just as Hood said.  (simultaneous posting) ;)
« Last Edit: March 07, 2008, 08:04:39 PM by Overloaded »

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 limit switch overide
« Reply #5 on: March 07, 2008, 03:54:50 PM »
RC not sure what you mean by "Soft Limits have to be OFF" but if you mean they have to be switched off before you can home then thats not so. If you find this then it could be the issues that softlimits have in Turn but for Mill they are fine.
Hood
Re: Mach 3 limit switch overide
« Reply #6 on: March 07, 2008, 04:09:03 PM »
Hello Hood,
I need to go check. I am referring to turn though. If the SL is at 0, it will home with them on but if SL is before the home sw., I thought the SL would inhibit the home sequence.
I'll check later.
Thanks,
RC
If I put the tailstock on my lathe, the carriage will hit it when homing. That's why I set the SL 1" Z- of the home sw. And if I remember correctly, no bets, I had to remove the tailstock and turn off the SL to ref. It a homemade lathe with only 2 bed rails.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 limit switch overide
« Reply #7 on: March 07, 2008, 04:19:35 PM »
Yes but really your soft limits should always be set to your axis extreme travels although lathes are a pain in the a***.
 If like me on my Lathe you have a home switch that is not at an extreme then you need to set up a Home Off value so that the actual machine zero is at the extreme of the axis. Soft limits dont work great on the Lathe as you know, well they work but the Out Of Limits message you get when starting the code doesnt work correctly but the actual softlimits do.
 To be honest I dont use softlimits on the lathe, I did for a while have X only softlimits set up as the Z with tailstock is ever changing and is a real pain.
On a mill or a router etc softlimits are great.
 
Hood
Re: Mach 3 limit switch overide
« Reply #8 on: March 07, 2008, 04:21:08 PM »
Yes Hood ....You are correct as usual. I must have confused this with that other issue.
Thanks for the correction,
RC
Re: Mach 3 limit switch overide
« Reply #9 on: March 07, 2008, 09:44:00 PM »
Thanks guys. I got things working, with your help