Hello Guest it is October 22, 2019, 07:55:42 AM

Author Topic: Jerky motors on slow feed rate  (Read 2250 times)

0 Members and 1 Guest are viewing this topic.

Jerky motors on slow feed rate
« on: March 07, 2008, 05:37:33 AM »
Dear friends,
I'm new in the discussion. I write from Italy and I use Mach3 version R.1.83.
I have a strange problem using slow feed rate (actually >50 and <150 mm/min and the worst is 100 mm/min).
I was afraid of high feed rate but then problem is on the contrary.
As "destructive test", I've tested my machine at 1500 mm/min with hard acceleration, jogging and working and everything is OK! No missing steps.
As I feed at 100 mm/min then motors begin jerking very evidently (even vibrating forward and backward for a while)
If I jog them in the same direction the problem is not so evident: it appears when changing direction.
I have tried everything:
new powerfull power supply, shielded cables, new computer (but the computer are PIII 650/1000 WIN 2000 newly installed, driver test really shows picks higher than the suggested), new printer cable, every possible suggestion found in the forum (backlash, slow acceleration, pulse width, I suspected even wrong GCode) but nothing.
Same problems even with the newest limited version of Mach3 downloadable from the site...
Any suggestion?
Many thanks in advance

Antonio

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Jerky motors on slow feed rate
« Reply #1 on: March 07, 2008, 06:37:53 AM »
Antonio, it is possibly your computer, especially as you say that the drivertest is not very lean. You could try doing the optimisation steps detailed at the bottom of the downloads page.
 One other thing it may be is your drives may be needing tuned for resonance. I dont know whether your drives have this facility or not.
Hood
Re: Jerky motors on slow feed rate
« Reply #2 on: March 10, 2008, 04:14:56 AM »
Many thanks for the suggestions.
But yesterday I made some other tests that have been very successfull.
As I said I had very big problems on slow feed rate and not on very high. So I tried to activate the motors on HALF STEP (I was working with ENTIRE STEP and my hardware has some bridges to choose 1/2 , 1/4 and 1/8 step) and changing then step/unit to the double: everything was fine (to maintain the same mm/min the pulsing from the PC was doubled by the software).
Now, the final configuration is set to 1/8 step on the hardware and 533 step/unit (I have a 200 step/turn motor and a screw with a pitch of 3 mm) and I sounds pretty good.
I made some working simulations at the speed of 100 mm/min (the worst I had before) and then RETURN TO ZERO without evident errors.
I didn't found the cause but I solved so the problem... (well... I hope)
Many thanks for you help.

Antonio