Hello Guest it is October 13, 2019, 09:44:41 PM

Author Topic: MACH3 is starting the router on its own... Scarry!!!!  (Read 13446 times)

0 Members and 1 Guest are viewing this topic.

Offline Graham Waterworth

*
  • *
  •  1,887 1,887
  • Yorkshire Dales, England
    • View Profile
Re: MACH3 is starting the router on its own... Scarry!!!!
« Reply #10 on: March 03, 2008, 03:57:38 AM »
Post us a photo of the set up showing the relay, we may be able to get some ideas from it.

Graham.
Without engineers the world stops

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: MACH3 is starting the router on its own... Scarry!!!!
« Reply #11 on: March 03, 2008, 09:44:49 AM »
Hi Bruno

When your spindle switches itself on - does it stay on? or does it just 'blip' on then off again momentarilly?

have you experimented to see what happens if you use an alternative output pin?



Re: MACH3 is starting the router on its own... Scarry!!!!
« Reply #12 on: March 03, 2008, 09:57:39 AM »
Nope, It stay on until I manually turn it off.
I will try to switch the pin and let you know.
Thanks for the help,
Bruno

vmax549

*
Re: MACH3 is starting the router on its own... Scarry!!!!
« Reply #13 on: March 04, 2008, 12:35:31 PM »
When you say manually turn it off how are you doing that???

Through mach or a switch?

(;-) TP
Re: MACH3 is starting the router on its own... Scarry!!!!
« Reply #14 on: March 04, 2008, 12:49:19 PM »
With Mach swittch
Bruno

vmax549

*
Re: MACH3 is starting the router on its own... Scarry!!!!
« Reply #15 on: March 04, 2008, 08:11:11 PM »
Double check all your pin/port setting to make sure there are NO duplicates involved. SOmething inside of mach has to be turning it on.

(;-) TP
Re: MACH3 is starting the router on its own... Scarry!!!!
« Reply #16 on: March 05, 2008, 08:55:47 AM »
I'm very fond of my pin 1 strobe safety, which locks out all power to the contactors unless it can see 12.5KHz on its pin - And since mach3 starts in Estop mode, it hasn't clunked once since i wired the thing in. I could hear a few clunks and grumblings from the relays and contactors before i fitted the strobe safety, it's dead quiet during startup now. I'm also putting in an interlocked safety for tool changing so that not even an M3/M4 command will start the spindle while a tool's being changed. Worth doing since i won't be the main user of this machine... other people's fingers are VERY expensive.
Re: MACH3 is starting the router on its own... Scarry!!!!
« Reply #17 on: March 05, 2008, 09:43:59 PM »
not sure if this is any help but I wired my spindle through 2 relays in series throught the NO contact of one relay to the NC contact of the other. Which means the only way the spindle can start is if output 1 is on and output 2 is off (which should only happen when Mach is in control). If I yank the parallel cable out (or the PC restarts when the milll is connected) all the relay ouptus float high, all the relays activate and the NC contact breaks so the spindle can't run. Since I have more relay outputs than I'll ever need I'm also running the stepper power supply through 2 relays the same way so they're only powered up when the enable output is on. I'll probably install a charge-pump at some stage so this is a temporary solution.
Re: MACH3 is starting the router on its own... Scarry!!!!
« Reply #18 on: March 05, 2008, 11:00:52 PM »
This idea with two relay in series seems interesting would you share a quick wiring schematic?
Thank you
Bruno
Re: MACH3 is starting the router on its own... Scarry!!!!
« Reply #19 on: March 06, 2008, 01:51:42 AM »
something like this - but if your output from mach is somehow turning itself on it's probably not going to help... This only inhibits the spindle if Mach isn't running or the PC reboots.