Hello Guest it is October 15, 2019, 01:41:19 PM

Author Topic: Mach3R3.037 & Windows Task Manager CPU % Load  (Read 3473 times)

0 Members and 1 Guest are viewing this topic.

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Mach3R3.037 & Windows Task Manager CPU % Load
« on: February 29, 2008, 06:20:54 AM »
Hi, All

Running Mach3R3.00.37 hear On two computers at home for testing and Internet use and Mach Support. Both around 2.000 mhz and 2 gigs Memory,

One Dedicated to Mill/lathe Testing, No Internet, Minimal Programs open at a time.

The other, 3 monitors,, 8 or 9  programs running  all the time, Cad, Internet, Skype, You name It, I think there's a Kitchen sink hooked up on this one somewhere.

For the most part, Both Run Mach3 Just Fine, This one the sink drains slow from time to time and causes "Pul's Int." to be a little wacky sometimes.

Have a couple of questions dealing with CPU % usage.


1. When running a G-code file with or without M30 or M02 at the end of G-code, CPU usage returns to 00-06 % when finished.

When running a G-code file and Feed-Hold or Stop is used, CPU usage romaines high, Sometimes 85-95 % CPU usage in Tool-Path page "Larger View Screen more CPU required".

If you change Screen/Pages, "Remember your still in feed-hold or Stop", But the CPU Speed then Drop's to 00-06 %.

Shouldn't it fall to this, Without switching Screen/page's ?


2. I've noted in MDI & MPG Moves, The View-Screen's doesn't update to it's True Position after a move.

It only updates on/during the next move sequence or a mouse click "In the screen view area".
 
This doesn't appear to happen while running G-code with or without a Feed-Hold or Stop. Been this way for a long time.


3. Is the Mill feed-hold Jog inhibit going to be Reinstated, It seems to be working in Lathe ?


4. Do you think Item "1" may be causing some of the issues with MDI, JOG, Macro's and VB-scrip's ?

CPU Load can Creep up to 98/100 % at times and if you Minimize Mach in this state, You Can't Do Much At ALL in Windows, The Pic below took a lot of fiddling to get .

My Temp Fix Hear is, Change Screen/Pages back and forth a couple times in Mach3 before Minimizing to do other Windows Work.

Thanks, Chip
« Last Edit: March 06, 2008, 11:34:24 PM by Chip »

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Mach3R3.037 & Windows Task Manager CPU % Load
« Reply #1 on: March 04, 2008, 07:08:03 PM »
Hi, All

I've narrowed this problem down a little, It seems to be more prevalent in G-code files with A axis moves.

Mach3 in Feed-Hold or Stop usually reduces CPU usage to 00-06 %.

The Issue I'm having is when running the following code on Feed-hold or Stop in Tool Path screen the CPU stays at 70-90 %.
(Bigger view screen more CPU usage).

This also cause's, MDI, MPG and Safe Z hight to not work after Stop is Pressed, Sometimes.

The only way to get the CPU back down to 03-06 % is to change screen view's.

Even after changing screen's an additional Stop is Sometimes needed Again to regain, MDI,MPG and Safe Z Function.

Maybe some other's could try this, Cause one "squeaky wheel" will never/almost never get the Grease/Fix.

Ctrl-Alt-Delete to bring up Task Mansger, Size it down, Options Tab check it for "Always On Top", Use Process or Preformance Tab to View.


G90 (INC First)
G00 x0
g01 z -.25 f100
g91 ;inc move set
G01 x2.5 A720 f1000
g90 ;abs move re-set
g00 z0
g01 z -.25 f100
G01 x5 A1440 f1000
g90 ;abs move re-set
g00 z0
g00 x0 a0
M30
%

Hears a screen set to view it with.

Thanks, Chip
« Last Edit: March 05, 2008, 11:01:18 PM by Chip »

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Mach3R3.037 & Windows Task Manager CPU % Load
« Reply #2 on: March 05, 2008, 04:15:46 PM »
Hi, All

Mach loaded with above G-code,

Next three photos, Feed-Hold, Stop, Only Screen Change brings CPU back down.

A axis "on" in ports & Pins, View Screens On, Next three photos, Feed-Hold, Stop and Screen Change.

Only Screen Change brings CPU back down to normal

Thanks, Chip
« Last Edit: March 07, 2008, 01:09:43 AM by Chip »

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Mach3R3.037 & Windows Task Manager CPU % Load
« Reply #3 on: March 05, 2008, 04:19:05 PM »
More Pictures

A axis "off" in ports & Pins or by "Turning Off " view Screens, Next two photos, Feed-Hold, Stop and CPU back down when ether method  is used.

Thanks, Chip
« Last Edit: March 07, 2008, 01:11:22 AM by Chip »

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Mach3R3.037 & Windows Task Manager CPU % Load
« Reply #4 on: March 07, 2008, 12:42:40 AM »
Hi, All

If You turn off A axis in ports & Pins or Turn "off" View Screens the problem seems to Go Away.

Updated Pic.'s Today, Ref. Windows Task Manager's Mach3 CPU % for each Picture

"View Screens" are Causing this Problem

This is repeatable on two computer's hear.

Thanks, Chip
« Last Edit: March 07, 2008, 01:17:18 AM by Chip »

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Mach3R3.037 & Windows Task Manager CPU % Load
« Reply #5 on: March 07, 2008, 12:32:40 PM »
Hi, Brian

Tool Path OFF Pic's

Thanks, Chip
Re: Mach3R3.037 & Windows Task Manager CPU % Load
« Reply #6 on: March 24, 2008, 07:46:47 PM »
Looks to me that your CPUload has everything to do with your Toolpath and not VB.. I am looking into a rewrite of the toolpath code.. Should get started in a few weeks or so ;)
Thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com