Hello Guest it is October 15, 2019, 08:56:19 PM

Author Topic: 6axis screen, default X-Z plane, default feedrate problem  (Read 3234 times)

0 Members and 1 Guest are viewing this topic.

Offline ayhan

*
  •  12 12
    • View Profile
6axis screen, default X-Z plane, default feedrate problem
« on: February 21, 2008, 05:25:46 AM »
Hii, everyone,

1. I used to use 6 axis screen before , after I re-installed mach3 again it did not worked , buttons can not be seen.
Does anyone know the reason.
2. How can I set active plane as X-Z as default ?
3.How can I change the feedrate as default ?

Thank you from now ,
Ayhan

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: 6axis screen, default X-Z plane, default feedrate problem
« Reply #1 on: February 21, 2008, 11:38:26 AM »
The active plane is set under General Config.

As far as I know, under Mach 3, the maximum feedrate - i.e. G0, is set when you set up your axis motors. What you set there becomes your maximum feedrate. If you want to slow it, then you need a G1 F*** command.
Not me driving the engine - I'm better looking.

Offline ayhan

*
  •  12 12
    • View Profile
Re: 6axis screen, default X-Z plane, default feedrate problem
« Reply #2 on: February 22, 2008, 02:28:52 AM »
thank you jimpinder,

I still test my machine , 5 axis is working , If we forget to change active plane as X-Z in the morning , than it crash. It is same like the feedrate , as default it is 6.00 , but I use 3000. Anyway it is easy to write Go and F*** , but , active plane is more dangeorus.
There may be to change them as default.
 

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: 6axis screen, default X-Z plane, default feedrate problem
« Reply #3 on: February 22, 2008, 02:54:32 AM »
Yes - Mine is set on XY and I have not needed to change it. I have tried on this computer (which is not connected to a machine) and I can change it to XZ or YZ, but even if I save settings, when I close the program and then restart it, it always resets to XY

We will have to have help on this !!

I do not understand your feedrate - 6.00 appears to be in inches but 3000 appears to be in millimeters.
If you have set up your machine motors in inches then 6.00 is the maximum you will get - the figure does not change if you use G21 - you must change that manually.
Not me driving the engine - I'm better looking.

Offline ayhan

*
  •  12 12
    • View Profile
Re: 6axis screen, default X-Z plane, default feedrate problem
« Reply #4 on: February 22, 2008, 03:33:00 AM »
Yes I use metric system ,

On the other hand Mach3 is started to not accept my last line "M30".
When I click "load g code" I can not see the last line "M30" ,
It is new problem ,
Do you know the reason.?
My g codes are very short
G00 Z10
G02 X80 Z-12 A180 R10
G28
M30
And save them as "TXT" or "NC"
Nothing more in the beginning nothing more in the last.
Do I have to write something in the beginning ?

I see some g codes they write many g code numbers in the first line
is it the reason ? 

Re: 6axis screen, default X-Z plane, default feedrate problem
« Reply #5 on: February 22, 2008, 07:11:16 AM »
Hello ayhan,
Here is a topic that explains the last entry of code.  http://www.machsupport.com/forum/index.php/topic,5206.0.html

The first line is to insure that Modal commands are properly set. (See pic.)
RC
« Last Edit: February 22, 2008, 07:19:16 AM by Overloaded »

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: 6axis screen, default X-Z plane, default feedrate problem
« Reply #6 on: February 22, 2008, 08:56:28 AM »
ok to have your default feedrate you can put F**** into the initialisation box, you will find that on the General config page. This will mean each time you start Mach it will default to whatever speed you have entered.
 Your question about not seeing the M30 ius because you have not terminated the last line of code by moving onto the next line. You need to press the return key after the M30 so that line is now terminated, it is good practice to put something like the % sign on the last line, that way you are sure you have terminated by pressing the return key. Here is an example of your code showing what I mean
G00 Z10
G02 X80 Z-12 A180 R10
G28
M30
%


Hood