Hello Guest it is October 23, 2020, 03:45:45 AM

Author Topic: Metric/English unit help  (Read 7902 times)

0 Members and 1 Guest are viewing this topic.

Metric/English unit help
« on: February 11, 2008, 01:53:58 AM »
Hi All,

I recently got my first real g-code from a part I made loaded on to Mach3.  I created the part in Engish units but the CAM program converted it to metric . So, I can see that the gcode has rather large units, so they are metric.  How do I tell Mach3 they are metric and not English units.  I think my Mach3 is reading the gcode file in inches and it does not have room to run the program with out exceeding the physical dimension of the machine (Rockcliff Router)  The code calls out fog Gx25 but it want to travel 25 inches instead of the proper 25mm.  Is this clear?

Thanks,
skipper

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Metric/English unit help
« Reply #1 on: February 11, 2008, 02:27:16 AM »
G21 at the start of the code will tell Mach its metric, G20 will tell Mach its Imperial.
Hood
Re: Metric/English unit help
« Reply #2 on: February 14, 2008, 01:06:52 AM »
Hi All,
you mentioned that the G20 or G21 should be at the begining of the program.  It seems that my programs do not have this when I load the Gcode.  I see that it is on the top line (see pictue) but how do I edit that line?  I ended up trying to edit the program by adding the G21 line and it worked. Is the machine suppose to add the line automatically?

Also, I have attached another picture.  Why does the program start so far away from where it is going to start cutting (see pic).  The x-coordinate is over 200mm away from the part.  If I zero my axis at the corner of my parts, shouldn't that be where the mill should be located to start cutting?
thanks,
skipper
Re: Metric/English unit help
« Reply #3 on: February 16, 2008, 04:09:52 PM »
Hi Skipper...

 I have the reverse problem...  I got my .tap file working... but it was done in inches... and for some dopey reason I chose mm for the default.  How did you edit the line to change the G21 to G20 ?

I remember in the first video it said basically that once you chose a native unit, you were pretty much stuck with it.. does this mean that I have to uninstall/reinstall to change the native units?

 thanks in advance...
 Larry
Re: Metric/English unit help
« Reply #4 on: February 18, 2008, 02:29:48 AM »
Hi Larry,

Right next to the start cycle button there is a button called "Edit G-code".  This will bring up the G-code file into Notepad which will allow you to edit it.  I was not sure really what I was doing but I added G21 on the 3rd or 4th line of where the g-code began and hit save.  The program seemed to work after that with the correct scaleling.  The top line that I circled, I am not sure how to edit that line.  Hope this helps, I am just learning all this stuff myself.
skipper

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Metric/English unit help
« Reply #5 on: February 18, 2008, 02:54:48 AM »
All G-Code should have a G20 or G21 in it so that the machine knows but in reality this seems not to be the case a lot of the time, more so for Imperial ;)
 As skipper said editing the code is simple enough to do but some people like to make up two profiles for Mach, one metric, one imperial. Depending on what code they awill be running they start Mach with that profile.
 Another thing that can be done if you dont want to edit the code for some reason is just go to the MDI line and type in G20 or G21 .
Hood

Offline Chaoticone

*
  • *
  •  5,628 5,628
  • Precision Chaos
    • View Profile
Re: Metric/English unit help
« Reply #6 on: February 18, 2008, 03:51:53 AM »
Another way may be to add the appropriate code to your Initialization string in General config.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Metric/English unit help
« Reply #7 on: February 18, 2008, 11:41:42 AM »
Thanks so much, it is working now and appears to be correct.

 Thanks again! ;D
Re: Metric/English unit help
« Reply #8 on: October 30, 2017, 09:46:40 AM »
 I edited the roadrunner file and changed the very first line to G20. It is still engraving at the same small size. Should I change some other setting?

Offline Tweakie.CNC

*
  • *
  •  8,511 8,511
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Metric/English unit help
« Reply #9 on: October 30, 2017, 11:49:51 AM »
Hi Pudly123,

The G20 should do it.

However, try some of the files in the zip folder here (I have tried them all and know they are OK) http://www.machsupport.com/forum/index.php/topic,18345.0.html

Tweakie.
KEEP SAFE !