Hello Guest it is August 18, 2019, 07:44:26 AM

Author Topic: jerky servo Mach3  (Read 5577 times)

0 Members and 1 Guest are viewing this topic.

Offline Ed

*
  •  15 15
    • View Profile
jerky servo Mach3
« on: February 09, 2008, 11:28:21 AM »
I have just built a new table and power supply. I'm using 320 gecko's . I have been up for days tyring to get this wright. The table runs perfect in jog mode. But when I run code that I run on my stepper table it is very jerky and misses steps. I hate to ask but could someone Please help tune these motors in mach3.
Thanks Ed

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: jerky servo Mach3
« Reply #1 on: February 09, 2008, 11:40:16 AM »
Make sure your Jog is set to 100%, could be that you have a slow Jog set up so that when you are tuning your motors it is not at your true rapid speed and as such when you are running the code it is exceding the limits.
 I dont have any experience with Geckos servos so cant help there I am afraid :(

Hood

Offline Ed

*
  •  15 15
    • View Profile
Re: jerky servo Mach3
« Reply #2 on: February 09, 2008, 12:05:48 PM »
My jog is at 100%. It will jog around at 100 units smooth but running code at as little as 6 units it jerks and misses step's.
Thanks Ed

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: jerky servo Mach3
« Reply #3 on: February 09, 2008, 12:15:09 PM »
If you write code with all G0 moves does it work smoothly?

Offline Ed

*
  •  15 15
    • View Profile
Re: jerky servo Mach3
« Reply #4 on: February 09, 2008, 09:06:58 PM »
I would have thought someone had ran across this. I changed my kernel speed from 25000 to 45000Hz and the table runs perfect. But I had my motors set to 100 velocity. My jog runs at 200 so I have to set velocity at 50. Now my table jogs at 100 units. Why is this is there some other setting in the motor that I'm not getting. Even though I'm very happy with my new table now its runs very smooth.
Thanks Ed

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: jerky servo Mach3
« Reply #5 on: February 10, 2008, 04:20:51 AM »
What version are you using?
Hood

Offline Ed

*
  •  15 15
    • View Profile
Re: jerky servo Mach3
« Reply #6 on: February 10, 2008, 02:50:13 PM »
The Newest one.
Ed

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: jerky servo Mach3
« Reply #7 on: February 10, 2008, 05:55:04 PM »
You mean the development version or the lockdown? If its the dev one try the lockdown.
Hood

Offline Ed

*
  •  15 15
    • View Profile
Re: jerky servo Mach3
« Reply #8 on: February 11, 2008, 12:13:30 AM »
This is what I'm using Mach3VersionR2.63. What causes the kernel speed to to affect the volicity speed. Now even if I which back to 25000Hz it only jogs at half the speed.
Thanks Ed

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: jerky servo Mach3
« Reply #9 on: February 11, 2008, 02:26:01 AM »
Ed
 Kernel speed will alter the velocity if you have your motors tuned for example near the max at 35KHz then turn down the Kernel you obviously wont be able to reach this speed. However yours seems kind of the opposite and I just dont have an answer apart from to try and re download and install again.
 If you attach your xml I can have a look and see if I can find a problem.
Hood