Hello Guest it is October 16, 2019, 09:09:53 PM

Author Topic: Stumping Motor Problem  (Read 3587 times)

0 Members and 1 Guest are viewing this topic.

Stumping Motor Problem
« on: January 17, 2008, 10:10:00 AM »
I have recently finished my first hobby cnc project and i purchased a driver on eBay for cheap, maybe not a good idea. I have managed to get the motors moving very smoothly with jogging, by adjusted the pulse width etc. I added the z axis and started having problems, although the x and y were moving beautifully the z wouldn't move, the only way i could get it to move was turn the pwm pot all the way back, which gave me the result of all motors moving with quite a bit of torque. As soon as a started running a program, the motors wouldn't move, i had to go turn the pwm up so they started moving. I don't understand why the motors would move perfectly fine while jogging and stop as soon as i try and run a program. Can anyone help me?

Thanks in advance.

Dwayne

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Stumping Motor Problem
« Reply #1 on: January 17, 2008, 02:00:38 PM »
Hi, Dwayne

Just a stab in the dark. Mach3 Startup "Feed-rate" is F6.0, If you've done all your tuning at this feed speed with your Arrow keys.

When you run Roadrunner file, It's F-speed is F60.0, Maybe causing your problem.

Re-Tune your drives with G00 moves on the MDI Screen, MDI Input line, Click on it and enter G00 X## example, Then Enter Key.

This will let you setup your Velosity & Acceleration for G00 Max Speed Moves Without stepper slips or servo trips.

Steps Per wont change if you've already set them up.

Give  US more infio if this isn't it.

Hope this Helps, Chip

 
« Last Edit: January 17, 2008, 02:51:49 PM by Chip »
Re: Stumping Motor Problem
« Reply #2 on: January 17, 2008, 03:22:06 PM »
Thank you for your reply.

I type in G00 X50, and nothing, i've adjusted stuff, still nothing, what is wrong?

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Stumping Motor Problem
« Reply #3 on: January 17, 2008, 04:04:52 PM »
Hi, Dwayne

Could you give us a little more info, stepper or servo, ver. of Mach, computer basic spec. ?

Thanks, Chip
Re: Stumping Motor Problem
« Reply #4 on: January 17, 2008, 04:59:45 PM »
I am running Mach3, windows XP, 3.0 Ghz, proc, intel M/B

I got the MDI jogging to work, but it still doesn't help, Right now i can run the roadrunning ok, but when i try and jog the motors just sit there and make noise.

Thanks for your help
Re: Stumping Motor Problem
« Reply #5 on: January 17, 2008, 05:24:07 PM »
Stepper Driver: MC433

I can get the x and y axis functioning perfectly but the z axis does not move with the same settings. I have to readjust the Pulse width in order for it to move, and soon as i do this, the x and y stops working.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Stumping Motor Problem
« Reply #6 on: January 17, 2008, 05:57:45 PM »
Sounds like you need to tune  your motors. Go to Motor Tuning page and lower the velocity and Acell and then start raising a little at a time until you get the sweet spot.
Hood
Re: Stumping Motor Problem
« Reply #7 on: January 17, 2008, 06:10:31 PM »
I have tuned the motors but no matter what i do i cannot get the Z axis to cooperate, same motor same everything. It just just there and makes noise.
« Last Edit: January 17, 2008, 06:12:50 PM by dwschool »

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Stumping Motor Problem
« Reply #8 on: January 18, 2008, 02:30:53 AM »
Have you tried swa[[ing your hardware around, ie try the X drive on The Z motor etc etc.
Hood

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Stumping Motor Problem
« Reply #9 on: January 18, 2008, 07:59:20 AM »
Hi, Dwayne

Have you found the pop-out jog window, Hit the TAB Key. Arrow Key's will only work in Screen's with Jog ON/OFF Button in them.

In the TAB pop-out Jog window set the "Slow Jog Rate" to 100 % and "Jog Mode" to Cont.

Under "Operator" there's a Auto-Calculator feature you can turn on, There are So-Many Bell's & whistles, Ring-Rine-

Your version of Mach3 is under "Help", Click on "About".

In ports & pins, motor outputs, Are your Dir & Step Low Actives all the same. ? Thy should be ether all "X's" or "Checked".

Some cont. boards won't work in the wrong state, Some work in ether, Some better in one State.

If an Axis is Backwards, Use Homes & Limits, to reverse axis, "Reversed Coll-um"

Hope this Helps, Chip