Hello Guest it is November 22, 2019, 08:06:16 AM

Author Topic: problem getting mach3 to make my motor turn  (Read 12623 times)

0 Members and 1 Guest are viewing this topic.

Offline ataxy

*
  •  31 31
    • View Profile
problem getting mach3 to make my motor turn
« on: January 16, 2008, 11:14:01 PM »
ok i have posted this on cnczone but i said to my self this is the mach forum after all

ok i just bought a kit from keling i did the setup and rechek it on the phone with the guy from keling and he says that all is hooked up properly and that my trouble is with mach3 and the pc
so here goes
pc spec
athlonxp 2400+
asus a7n8x rev1.04
1gig ddr 333
40gig hdd
radeon 9800pro 128mb
winxp pro sp2 with all current update

mach3 the latest trial
cnc component are
1x 48v/7.3a psu
3x kl6050 driver
2x 495oz 4leads motor
1x 640oz 8leads motor
1x c10 bob
as for the 5v required for the c10 its connected straight to the computer 5v line wich read as 4.95v on the multimeter

currently i have only one motor hooked up and the shaft lock when i turn on the setup
now port&pin are set for the x axis to step2, dir3 as for step and dir active low is enabled, port for step and dir is set to one and i have enabled e stop as it says in the info and vid tutorial
now here is my problem the motor wont move
i currently have my lpt addy set to 378 but strangly enough when i go in the resource tab of my lpt port i have two addy there one is 378 the other is 778 but my mobo only as one lpt port the guy from keling think my problem might be there what do you think and does anybody have or had a similar problem

edit: forgot to add in the bios the lpt port is set to ecp/epp 378/irq7

Offline ataxy

*
  •  31 31
    • View Profile
Re: problem getting mach3 to make my motor turn
« Reply #1 on: January 17, 2008, 11:50:54 PM »
to see a follow up of this problem check the mach yahoo group
Re: problem getting mach3 to make my motor turn
« Reply #2 on: January 20, 2008, 01:14:08 AM »
I have a similar problem, May machine works fine under K Cam but with Mach 3 the motors dont turn. I can togel the emer stop on pin 10 but that is all I have spent Days on this. Any Tips
Re: problem getting mach3 to make my motor turn
« Reply #3 on: May 07, 2008, 02:01:07 PM »
Guys,

FYI
I had a similar sounding problem with the C11 BOB. I would hear some noise from the motor as if it was turning but it was basically locked apart from some random "jumps". The answer was so simple it turned out, yes very red faced me. :-[  I used the XML file from CNC4PC webpage and it turned out the STEP/DIR pins were reversed. I assumed it was correct and then went on to look at hardware problems.
I dunno if it applies to the C10 however.

Hope it helps. :)

Re: problem getting mach3 to make my motor turn
« Reply #4 on: March 06, 2012, 10:38:19 AM »
Hello
Did anyone ever find the answer to this problem? I am having the same problem now. I looked everywhere I could think of. I have it hooked up the way they tell me to. I tried to get a answer from Keling no help. Does the C10 work with Mach3, or is my computer configured wrong (Mach3)?  Thanks

Offline Zilna

*
  •  11 11
    • View Profile
Re: problem getting mach3 to make my motor turn
« Reply #5 on: March 15, 2013, 07:23:46 PM »
Similar problem here as well, really need some help with this. This is now the third day and still no motors turning. We ordered our setup from automation technology and cannot get any decent support. Seems one person answers the phone with a simple "hello" (my guess is that it's the guys personal number) and then barely let us get a word in edgewise to even describe the problem. He insisted that we email the problem to him ... really? Already got him on the phone but I need to email him? After a little bit on the phone with him he is stating that we have our unit wired up properly and that the problem is with Mach3.