Hello Guest it is October 20, 2019, 05:46:35 AM

Author Topic: help with z axis creeping  (Read 7481 times)

0 Members and 1 Guest are viewing this topic.

help with z axis creeping
« on: December 22, 2007, 05:35:43 PM »
Greeting to All,

I am having a problem locating the problem (and a fix) for my z axis.  It gradually "gains" height as the job progress. It is most noticeable when doing complex carvings such as those in vcarve that require a lot of small z axis movements.  By the end a job it may have "added" as much as an inch.  I usually end up carving fresh air.  The x and y axis seem to be working great even with a high demand of detail.  I have made some successful engravings such as my name and other basics like circles, squares etc.  Here is what I have and what I have done so far. Any other advice?

Equipment/Software:

Sosylva designed cnc router (the large one, all belt driven), A dedicated P4 3.2 ghz w/XP Pro, Registered Mach 3, Vcarve Pro 4.5, Xylotex 3 axis board, CNC4pc BOB.  There were no "known" modifications to any design and all parameters were meticulously set according to ALL of the aforementioned documentation. This machine runs like a dream and has since day one.  The 289 oz steppers run very smooth at available speeds or accel. 

With all of the possibilities like missing steps, resonance, binding, noise, settings, etc......Here is what I have tried so far:

1.  Lots of reading and re-reading of all manuals/instructions.
2.  Lots of reading and re-reading of forums like this one.
3.  Changing the active low/high setting for step and dir.  (no change)
4.  Tried various speeds and accelerations.  My last one was 15, 1.  (no change)
5.  Rechecked the xylotex board for proper voltage ref - 3.35  (no change)
6.  Reduce the likelyhood of noise by using shielded cable and not with any power cables.  I do not have limit or home switches yet.  (no change)
7.  Adjusted the debounce intervals, now at 5,000.  (no change)
8.  Finally, I removed the belt and gears completely from the zaxis and made a reference mark on the back of the stepper and ran a "dry" run under no load.  I have repeated this with x & y disabled as well as the spindle motor off.  (NO CHANGE)

Any thoughts?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: help with z axis creeping
« Reply #1 on: December 22, 2007, 05:44:41 PM »
Tried swapping X or  Y axis drive for Z, I am not familiar with the Xylotex drives but I presume that even though its a 3 axis drive system each drive will be kind of independant.

Hood
Re: help with z axis creeping
« Reply #2 on: December 22, 2007, 06:12:36 PM »
Thanks for the quick reply Hood,

I just tried it with the same results.  I am still doing this with no load and the other two axis disabled to eliminate at least a few variables.  Would changing the microstepping to 1/4 rather than 1/8 help?  If so, should it be done for all axis and will it affect the resolution greatly?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: help with z axis creeping
« Reply #3 on: December 22, 2007, 06:16:19 PM »
OK next thing I would do is configure the X or Y axis as the Z axis in Mach and see if the X or Y now loses position.
Hood

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: help with z axis creeping
« Reply #4 on: December 22, 2007, 06:18:48 PM »
Hi, Charlie

In Motor Tuning have you tried setting the Step/Dir Pulses from 0 up to 5.

It will give your stepper control more time to see the Pulses from Mach.

Thanks, Chip

Offline Bodini

*
  •  216 216
    • View Profile
Re: help with z axis creeping
« Reply #5 on: December 22, 2007, 06:32:52 PM »
Are you sure it isnt in the g-code?  I'm just askin'.  :)

-Nick
Re: help with z axis creeping
« Reply #6 on: December 22, 2007, 06:38:53 PM »
Ok..Chip first,

Thank you.  Yes, I have tried step/pulses at ALL 0-5 using various vel. and acel. all with the same results.


Hood,  I just switch my x for the z and the z behaves in the same incorrect manner.

Just to clarify a little,  I am trying to execute a photocarve image.  These movements are so tiny that they almost seem to make the motor "chatter".

Let's keep going......

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: help with z axis creeping
« Reply #7 on: December 22, 2007, 06:49:50 PM »
Hood,  I just switch my x for the z and the z behaves in the same incorrect manner.

 Not sure exactly what you did here, what I was meaning was take the Z axis in Mach and configure it to the pins you currently use for the X axis. This means when you run the code the X axis will do the Z moves. If the X (now doing  Z moves) keeps position then its hardware, if it loses position then its software.
If this is what you did then apologies.

Hood
Re: help with z axis creeping
« Reply #8 on: December 22, 2007, 06:52:14 PM »
Hey Nick,

G-code?  It's certainly an option but I am still thinking no at this point.  The DRO in Mach3 is consistently displaying a safe travel of 0.200 during the project.which is what was set in the photocarve program.  The other axis seem to work great.  Photocarve, like Vcarve, has the ability to save the tool path according to a chosen post processor - in this case Mach2/3.  Although I am familiar with gcode to a point I am not sure what I would be looking for.
Re: help with z axis creeping
« Reply #9 on: December 22, 2007, 06:54:59 PM »
Hood,

Yes,  I did exactly as you described.  I am almost positive is NOT a hardware issue.  I just don't know where to go from here.  Something just ain't right.