Hello Guest it is March 04, 2021, 04:30:45 AM

Author Topic: Mach3 wont reference all home  (Read 7511 times)

0 Members and 1 Guest are viewing this topic.

Mach3 wont reference all home
« on: December 18, 2007, 08:08:34 PM »
Mach3 wont reference all home,nothing happens when I press the reference all home button it will only let me home in the diognostics page. Can anyone help me out with this? Thanks mike

Offline Chaoticone

  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Mach3 wont reference all home
« Reply #1 on: December 18, 2007, 09:31:53 PM »
What does it do when you try to refrence all home? Any messages? Are your home switches enabled? Is this a new set up up one that has ran in the past? Tell us more about your machine and set up.

;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach3 wont reference all home
« Reply #2 on: December 18, 2007, 10:54:28 PM »
I shut down the computer a couple of times and it works now.It must be something with the computer.
Re: Mach3 wont reference all home
« Reply #3 on: March 13, 2009, 06:51:19 PM »
I'm having the same problem.... the red square become green but the coordinate don't go to zero....
Last week reinstalling mach3 the problem has been solved. Now it persist.... (I'll try to format the hard disf and reinstall everything...).


Offline Hood

  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 wont reference all home
« Reply #4 on: March 13, 2009, 07:25:20 PM »
Go to Homing and Limits from Config menu and check the Auto Zero for each axis you want to zero when Homing.
Re: Mach3 wont reference all home
« Reply #5 on: April 06, 2015, 02:09:44 PM »
 If I try to home it will move about 2-5mm, stop and set all to green 0.

 What I did was chain all my relays from com, to C-CN-C exc all but the last one. It si NC-NC, C to LPT13, that way the last NO does not lose it's C. When I home I turn on the homes and off the X++,X--exc. that way it will not run into an Estop. So if I am say within 2-5mm it works, but if I am at the other side of the table (1250x660mm) I will end up with an 0,0,0 out in space.

 Another one I am ??? about is the motor speeds/settings. I run them in Motor Tuning and they perrrrrrr. When I run them from Gcode or MDI Input they either try to run out the door sounding bad or sloooooooooooooowwwwwwwwwwww. I ran the Cross.tap Gcode... Found the F5000 in it. By the time I got done adjusting it I was down to F75.

 Senses I am on a roll. The one I got this hole thing from shipped a VFD Mod: M150B 3ph 220v 0-400hz, 1.5kw, 8a. made by Electromtor co ltd. I am going to use it for a door stop. 99% of the time I get an Er.4 motor tries to start. The time I did get it going the breakout board went nuts. Or if I have the Gcode running I can not start the motor. I took a very long cable to the other side of the house with a GFI outlet. The same.
 Seller will not give me English documentation on it so HELP....