Hello Guest it is October 14, 2019, 07:47:02 AM

Author Topic: Help!!!! Mach gone crazy  (Read 4275 times)

0 Members and 1 Guest are viewing this topic.

Help!!!! Mach gone crazy
« on: December 06, 2007, 09:43:03 PM »
I'm running Mach2 (registered) so forgive me. Everything was fine the other day. I tried running some 4th axis stufff and the I & J commands were driving Mach2 crazy after I did a search & replace  substituting A for Y in the NC code.

Anyway I went to run a conventional job today (no A axis involvement) and the thing is feeding way too fast. My coded feedrate is .5 and 1 and the thing is running 6 even though the chosen feedrate display says 1. Mach defaults to FRO of 6 when initially booted up. THe readout indicates 6 and on Z retracts 15. I've checked every setting against the defaults and can't find anything. I've reduced the feed rate to %20 using the F10 key but it's still too fast and doesn't sound right.  :o I'd do a fresh install but it would be a royal pita to set all the ports, backlash etc. Any ideas? I've tried running the same jobs that I've run previously, and all exhibit the speed up issue.   
« Last Edit: December 06, 2007, 11:41:20 PM by rustyolddog »
Re: Help!!!! Mach gone crazy
« Reply #1 on: December 06, 2007, 10:30:11 PM »
Hey Rusty....
I had a similar situation with M3 once.
You say it is moving too fast, is it also moving too far ?
On mine, somehow the steps per unit changed. (I'm pretty sure I didn't do it, but not absolutely positive.)
Also, double check the units setting.
Just a thought.
Re: Help!!!! Mach gone crazy
« Reply #2 on: December 06, 2007, 10:52:01 PM »
No, it's not moving too far. It seems like the FRO is 6.00 no matter what. Even though I manually enter 1.0 and even thogh my Gcode is 1.0. Units is correct, none of my steps per unit have changed. Motors will stall on a rapid move. I'm getting a rapid of 55 which is way high for my system. I'm at my wits end here. All I can think to do is a new install and start from scratch. I've changed various setting but nothing seems to work. Any idea what the configuration file name is? Maybe it's corrupted.  It seems like it's related to the spindle speed setting somehow but I don't use Mach to control my spindle. I keep getting these two errors in the error file:

interpreter: cutter radius compensation off

Spindle Feedback too low for Feedrate Calc. Feedrate set to .1

If I MDI S1, the feed changes but not for the better.


Here's a clip from the error file

Thu - 22:31:10 ---Program Startup
Thu - 22:31:11 ---Driver re-initialised
Thu - 22:31:23 ---interpreter: cutter radius compensation off
Thu - 22:31:24 ---File Rewound.
Thu - 22:31:27 ---interpreter: cutter radius compensation off
Thu - 22:31:32 ---Spindle Feedback too low for Feedrate Calc. Feedrate set to .1
Thu - 22:32:09 ---interpreter: cutter radius compensation off
Thu - 22:32:14 ---Spindle Feedback too low for Feedrate Calc. Feedrate set to .1
Thu - 22:32:28 ---Minimum Speed of Spindle Reached, useing min speed.
Thu - 22:32:37 ---interpreter: cutter radius compensation off
Thu - 22:33:09 ---Minimum Speed of Spindle Reached, useing min speed.
Thu - 22:33:37 ---interpreter: cutter radius compensation off
Thu - 22:34:19 ---Minimum Speed of Spindle Reached, use lower pulley.


ETA: I've been running Mach2 for several years now on a laptop. Haven't had any issues with it, haven't done anything exotic with it. Other than the normal port settings, backlash comp, etc. It's been run with default settings. I configured my 4th axis this weekend to engrave a piece of tubing as a test, I did a simple search & replace substituting A for Y axis and it worked perfectly. There were no IJ commands in the Gcode. I took a graphic file and posted the g-code from it and repeated the test. The code was full of IJ commands whcih didn't sit well with Mach2 when I did the A for Y substitution. Frankly, I didn't notice the IJ commands right off. Anyway. the controler went a bit crazy driving the mill, the Y axis was moving when there wern't any Y's in the code. ANd the other axis were not moving correctly for the geometry. Anyway. I called that experiment quits because I had real work to do and here I am. All I can figure is something got corrupted.


This is the header from posted Gcode files:
%
O0000
N10 (MACH3 MILL - )
N20 (AUTHOR - )
N30 (GROUP - )
N40 (SYSTEM- ONECNC-XR2 MILL PROFESSIONAL - VERSION 8.35)
N50 (NOTES - NONE)
N60 G0 G40 G49 G50 G80 G94
N70 (ENGRAVING POINT ) ( )
N80 T1 M6 G43 H1
>>>>> I Delete this line from the code because it causes Mach2 to lock up if I have to E stop or Pause >>>>>>>> N90 S4400.0 F1.0 M3
N100 G4 P3

« Last Edit: December 06, 2007, 11:29:47 PM by rustyolddog »
Re: Help!!!! Mach gone crazy
« Reply #3 on: December 06, 2007, 11:28:00 PM »
I wish I knew more about CNC, I'm fairly new at it.
The reference to spindle rpm may be associated with feed per rev.(G95), as opposed to feed per min.(G94) .
I wish you the best, you ARE at the right place.
I just hope I don't misslead you.
Regards

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Help!!!! Mach gone crazy
« Reply #4 on: December 06, 2007, 11:52:56 PM »
It sounds to me like one day you were at 35Khz or 40Khz, then somethign happened and it went back to 25Khz..

Id check that and jump up to 35 or 45 if thats where you tuned the motors.. seomthing doesnt sound rigth though.. I cant figure why your at 6 all the time, thats not FRO that goes to 6, thats just the feedrate commanded display. FRO should be at 100%.

  SO try this, type F1 in the MDI line, then on the main page, does the feedrate read 1?

If you type 1 where the feedrate display is and hit enter,  does it change to 1?

What ahppens in the program now?

Art
Re: Help!!!! Mach gone crazy
« Reply #5 on: December 07, 2007, 10:31:08 AM »
Well I'm definately at 25kHz but I think that's where I've always been. If I recall, my laptop is a 400mHz processor, and that's why I don't run Mach3.

When I boot Mach2, the F is 6 on the display. If I manually enter F 1, it still runs at 6 in the Units/M indication. Programmed F is 1 as well.

I'll try the MDI entry tonite and and the pulse rate. Is there a configuration file(s) that I can save so I can restore any problem in the future? Would a Windows Restore possibly get me back where I need to be?

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Help!!!! Mach gone crazy
« Reply #6 on: December 07, 2007, 10:35:08 AM »
save your mach2mill.xml and reinstall.. then copy it back.. Sounds liek it may be the xml thats the trouble though. Id check all the motor tuning and retune myself.. seomthignis very screwed up..

Art
Re: Help!!!! Mach gone crazy
« Reply #7 on: December 09, 2007, 08:43:29 AM »
Well it's something with mach2mill.xml. I did a copy of the xml from a clean install on another computer and it seemed to run normally. For some reason ocx test wouldn't run. I resorted to a new install and proceeded to set thnings up again.

Offline Chaoticone

*
  • *
  •  5,604 5,604
  • Precision Chaos
    • View Profile
Re: Help!!!! Mach gone crazy
« Reply #8 on: December 09, 2007, 09:19:24 AM »
Where are you at now? Have you got it sorted?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Help!!!! Mach gone crazy
« Reply #9 on: December 09, 2007, 10:13:12 AM »
Where are you at now? Have you got it sorted?

Brett

Don't know. i won't have time until later today to run some test cuts. It seemed to operate normally last nite  (1a.m.) once I restored my key settings, port values, motor tuning, backlash comp values etc. But there are alot of other settings that I have no idea where they were. Things like soft limits, CV or Exact stop mode, the IJ mode. It ran at the correct feed rate when I did a quick test. Sure would like to know what went wrong & where. In the mean time, I'm looking for another used beater laptop so I can upgrade to Mach 3, no room for a desktop at the moment and support seems to be better than it is for older MAch 2. Need to burn my license file to a CD, almost messed up and deleted it.