Hello Guest it is July 05, 2020, 10:59:29 AM

Author Topic: Mach3 Startup- Reboots PC- help?  (Read 6561 times)

0 Members and 1 Guest are viewing this topic.

Mach3 Startup- Reboots PC- help?
« on: November 29, 2007, 08:58:00 PM »
Hi all, I'm new to the forum here. 
I have a Smithy CB1239XL combo machine with steppers on it.
I used to run Mach2 and it worked great.  I bought my steppers and drives too small and didn't get the position sensors, so sometimes it would miss a step and get out of alignment.
So I bought new Bigger Steppers and drives and now have Mach3 loaded on the PC.

My problem is when I double click the icon to start Mach3turn, it gives a startup picture and then the monitor go black, you can hear a relay clicking like it's changeing the resolution or something, then a get a brief flash of a blue screen with some text on it, then the machine reboots.

The machine is an AMD K5? 450 with 512M ram.  I've tried cutting out everything I can think of.  Also changed the display acceleration settings, put in a different video card, but no change.
Am I missing something basic here?

I have Mach3 loaded on this PC, Dell 3Ghz with 1.5G RAM... and it works fine.

Thoughts, suggestions?
Thanks

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Mach3 Startup- Reboots PC- help?
« Reply #1 on: November 29, 2007, 11:41:45 PM »
Hi, Lar45

Have you run the Driver Test, It's in C:\Mach3 folder, Let it run till it closes on it's own, If that doesn't do it run SpecialDriver the Original Driver can be reinstalled by running OriginalDrive.

I've had this problem after installing new versions of Mach also, Usually the driver test fixes it for me.

I run Video acell at lower end as LazyCam won't load if it's to high, For me anyway.

Hope this Helps, Chip
Re: Mach3 Startup- Reboots PC- help?
« Reply #2 on: November 30, 2007, 12:34:29 AM »
Thanks, I'll give that a try.
:)
Re: Mach3 Startup- Reboots PC- help?
« Reply #3 on: November 30, 2007, 03:24:39 PM »
I ran the driver test and got the same problem.
The program started and when it got to "Takeing Over 3, 2, 1"  The screen went blank, I heard some clicking in the monitor like it was changeing resolutions, then the PC rebooted.  I tried it again after that and got the same results.

Oh, and a correction on my initial post.  I ran Mach 2 on a different PC, I think this is the first time I've tried Mach 3 or 2 on this PC.  I think that I installed it about a year ago and didn't notice any problems.  I don't remember all of the details(CRS) sorry.

Any Thoughts?  and thankyou very much for your help.

Offline zealous

*
  •  492 492
  • HI!
    • View Profile
    • Artsoft Solutions
Re: Mach3 Startup- Reboots PC- help?
« Reply #4 on: November 30, 2007, 04:01:38 PM »
Try to uninstall, download the latest and dont forget to reboot after you install.
Re: Mach3 Startup- Reboots PC- help?
« Reply #5 on: December 02, 2007, 02:56:22 AM »
same problem.
I uninstalled, went into system manager and uninstalled the Mach X driver, rebooted, installed the latest Mach3, rebooted, and when I tried to start it, it rebooted the PC like before.
After the reboot, I tried the driver test and it also rebooted the PC.

Could it be that I don't have enough system resources to run it?
It's an AMD K(5or6(it's late))2 450 with 512 ram. I have a PCI video card with 32MB
 It's in the garage, so I'll bring it in and hookup to the network to download all the latest drivers for video...
Maybe I'll try Mach2 first and see if it will run.  Does Mach 2 and 3 use the same Mach X driver?

thoughts?
thanks

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Startup- Reboots PC- help?
« Reply #6 on: December 02, 2007, 04:43:52 AM »
Have you tried running the special driver? you will find it in the Mach3 folder, if this doesnt help then just re run the normal driver which you will also find in the Mach3 folder.
 Another thing to try might be the optimisation steps, you will find the steps to do on the downloads page.
Hood
Re: Mach3 Startup- Reboots PC- help?
« Reply #7 on: December 05, 2007, 09:47:52 PM »
It works!! Yeah!!  I ran the special driver and now the progarm starts and I have movement.
I had already done the optimization steps with my system being so marginal.

I have another problem now though.  I was setting up the motor tuneing and the step motor will turn fine for about 1/2 second then pause and start jumping.  It seems like it has a fairly regular pause instead of the motor running smoothly. 
I've only started playing with the X axis and the main lead screw and don't have any load on it with the halfnut disengaged.

I'm almost thinking that this might be because of the slow CPU, 450 AMD K6-2 with 512 Ram. 
THis is the first time that I've tried the Gecko drives though.  Before I had the Lini-Stepper home built kits.  The Lini-Stepper drives worked fine, but were just too small for my Smithy CB1239 XL combo machine.

I might just have to look at the Dell surplus site.  They have some pretty good deals on Scrath and Dent PCs.

Does Mach3 or Lazy Cam have any video card(ram) or DirectX minimum specs?

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Mach3 Startup- Reboots PC- help?
« Reply #8 on: December 05, 2007, 10:39:41 PM »
Yeeeeeeeee Haaaaaaaaaa, it's alive. Sounds like your Vel. may be tuned too high, or possibly it is out of the KHz range. What is your steps per, vel., and accel. set to in motor tuning? What Pulse rate mode are you set to in config. Ports and pins, port setup.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach3 Startup- Reboots PC- help?
« Reply #9 on: December 06, 2007, 03:15:42 AM »
It was in 25Khz so I left it there.  I tuned and calibrated the motors(only X and Y for now for the lathe).
X steps 16586, vel-20"/min, Acel 4"/min/min
Y steps 24686, vel 13"/min, Acel 3
They will run faster than that, but I thought I'd leave myself a little saftey room.
The steppers ran fine in the motor tuneing setup with the up and down arrows controlling the movement.
When Mach 3 tries to run G-code, the motors run terrible.

When I try running a simple G0 X.5 ,  then the motor stumbles and pauses, sometimes it turns backwards about 1/4 turn and then goes forwards again.  I tried giveing it a Feed of 5, (F5 ) and then use G1 X.5, and still got the same on both the X and Y axis.

I don't have any feedback for position sensors, but I don't think it is enabled.  ???

Any thoughts?  and thanks a bunch for all the help.
« Last Edit: December 07, 2007, 12:07:24 PM by Lar45 »