Hello Guest it is September 24, 2020, 11:01:27 AM

Author Topic: Help Please - Software issues?  (Read 3587 times)

0 Members and 1 Guest are viewing this topic.

Help Please - Software issues?
« on: April 12, 2006, 11:50:23 AM »
Hello,
I have been having a real tough time getting my Mach2 up and running. Some history, I have been using this software, on this computer, and on this machine for a year or more. I sold my home (garage shop) and started a business. Now I need my machine more than ever, and I can not get it to to things I know it should be doing! I re-installed the new version of Mach2 on my computer and checked the drivers, re-re-installed several times, both drivers and software.

When I run a pocket wizard, it will do the first cut lets say (.0625 below surface), then when it is time to retract to the rapid (z+.1000) it will stay at .0625, rapid move to the center of the pocket, and start to plunge from there. So, I stop the program and manually get the cutter out and send the machine back to 0,0,0 and all the axis's have now changed. The X will be off by some .50, and y by something like .09 and the z is way off. So, I go thru all the setups again and the machine will preform great - Till - I do a second pocket and this time it will do great, but when it is done and I send it back to 0,0,0, all the axis's will have shifted again, or it will plunge into the table, or it will go to the intended cut depth and just start cutting back and forth on the x axis.

It is acting like it is a License issue, or it is still in Demo mode and I cant get it to work correctly. It is starting to cost me a lot of Money and I am getting very concerned about this since there seems to be no sense to it all. Any and all help will greatly be apprecitated. I posted about a week ago asking for help and Brian was kind enough to contact me, but I have been spending all my time at the shop and have no internet access there yet. But today I had to leave work again and beg for help. The "code" seems to be posting correctly. When it does not retract to the rapid hieght, it was asked to in the code, when it plunges into the table, or something else funkey like that, it seems to have done its "Axis" shift as well.

Thank you in advance to all that could help. I am in dire straits here and need some help. Thank all.
Regards,
Glen
Re: Help Please - Software issues?
« Reply #1 on: April 12, 2006, 11:57:48 AM »
Oh,
I forgot to mention, I have installed and checked the drivers and run the Test and all seems well. I have a P4 and am only running at 25k, so that should not be a problem. The "Axis shifts" and the "Wacky" acting always happens on the second set of commands (ie - If I am running a pocket wizzard, the first pocket will be just dandy, the problems almost always happens when it preforms correctly thru the first string of commands then wacks out when it goes to do the second set of commands.

Then there is the times it will run a complete wizzard from beginning to end with nothing happening - And as luck would have it, that is when I have no cutter in and just testing to see if I some how managed to correct the problems.

Thanks again.
glen
Re: Help Please - Software issues?
« Reply #2 on: April 12, 2006, 05:32:23 PM »
Hello,
After coming home and writing the message above, I attempted more and simular resullts. When I got back I ran the Oxy test and the graph was all over the place. Earlier today it was a nice fuzzy line with no spikes. Now the test is showing more spikes than can be exceptable. I am going to try my lap top in the morning, but that is only a temp option for me now. Could the problems I am having be a product of the computer? It worked fine for a year or more, and now (after a serious crash that took my tech a few hours to get me back up and running) I am having trouble. And nothing that I can nail down. Just all kinds of funkie stuff happening.

Any assistance or recommendations would be appreciated.

Best,
Glen

ynneb

*
Re: Help Please - Software issues?
« Reply #3 on: April 13, 2006, 12:04:07 AM »
I am no expert here, but will suggest a few thoughts since you have made 3 posts and not had a responce.

You mentioned you have tried to reinstall Mach, out of interest did you uninstal the Mach driver by right clicking on My computer selecting properties, then device manager, and then removing the Mach engine. Updating your Mach install will not update this unless it is removed b4hand. Please DON'T FORGET the mandatory restart after you reinstall Mach again.

Have you done all the things that the optimisation text says? http://www.machsupport.com/optimisation%20XP.txt

You mentioned a serious crash that took the tech ages to fix. Is it possible that while most of the computer seems to be working, there is still a few faulty files etc. Could you do another install of windows beside your existing one, so that you can have a dual boot setup. Have Mach in the new windows, this way you will know its all completely fresh and optimised.

I am sorry I cant tell you the exact answer to your problems. Please let us know how you go.

« Last Edit: April 13, 2006, 12:07:12 AM by ynneb »
Re: Help Please - Software issues?
« Reply #4 on: April 13, 2006, 07:41:50 AM »
Thanks for the reply,
I have been thinking in the same lines as you. I am going to purchase a copy of XP  (yet another copy, i mentioned I have just sold a house - well here in lies some of the problem - no access to my software, paperwork etc - I lost control of the packing and this is a result) and just get another hard drive and install them both this morning. I will use the optomisation instructions you gave me (Thanks, I did not have that) and hope that this solves the problem(s). This thing is acting so over the board that I just know it is the computer.

Thanks again for your reply. I am at wits end here and appreciate any thoughts on the matter.

Regards,
Glen

ynneb

*
Re: Help Please - Software issues?
« Reply #5 on: April 13, 2006, 09:28:10 AM »
I guess hard drives are real cheap these days anyway, but there is no reason you cant have two particians on the existing hardy.
I would be interested to know how you go, please post back your results.