Hello Guest it is July 17, 2024, 11:33:17 AM

Author Topic: Steppers stuttering randomly when jogging full speed - MACH3  (Read 11071 times)

0 Members and 1 Guest are viewing this topic.

Hi,
I have a 2009 ez-router scorpion 4x8.
I have had a few of these machines and always had random issues I've had to solve apart from their tech support.

I'm having the following problems.
When jogging full speed 500in/min on Y and X and 187.5in/min on Z, I can get it to basically stall.
What I am trying to simulate is rapid moves when actually cutting materials, as it has had problem loosing steps.

So I took it a step further and disengaged the Z,X and Y steppers so they can run free to try and rule out mechanical.
I currently have my spindle off the machine and the spindle cable taken out of the cable tray as I am replacing it with a IGUS shielded soon.
So there shouldn't be any noise from the VFD as it is not run to anything.

I can still get random axis to stall when jogging them all around randomly. As far as I know the motor tuning should be from EZ-router themselves and the XML has likely not been changed...
I will attach some photos of the tuning, the xml file and a video showing the problem happen. Is testing the steppers this way not under load even a good idea? I know you can get false info when running them free of load?

Steppers are nema34 4.9a 1.8ยบ. I think ez-router rebrands them so info might not match up with anything online.
I believe drives are being powered by a Basler 40v 780va transformer
Re: Steppers stuttering randomly when jogging full speed - MACH3
« Reply #2 on: June 24, 2023, 05:52:37 PM »
Some new info, If I jog Y- full speed and try and hit Z- it will always stall. But not when I run Y+
When I run X+ and try and run Z- it will stall as well. But not the other way around...
Re: Steppers stuttering randomly when jogging full speed - MACH3
« Reply #3 on: June 24, 2023, 06:41:54 PM »
Another test I did was unplug power and output to both Y drives and ran the test in mach again full jog Y- and Z- and every time it still stalls the Z axis when moving the Y which isn't even plugged in via their drives.