Hello Guest it is February 27, 2024, 07:38:19 PM

Author Topic: Homing on Y Axis, 2 Motors (Slave), Limit Switch  (Read 1182 times)

0 Members and 1 Guest are viewing this topic.

Homing on Y Axis, 2 Motors (Slave), Limit Switch
« on: May 08, 2023, 01:37:49 PM »
Hi,

I am using the Pokeys57CNC with motors 0, 1, 2, 3 connected.

Motor 0: X Axis
Motor 1: Y Axis
Motor 2: Z Axis
Motor 3: Y Axis Slave

I've got two switches per axis (Limit -, Limit +). No dedicated home switches. Home is sharing the Limit - switches.

Problem: X and Z Axis is homing fine. Y Axis homes with both Motors, but if it reaches the Limit - switch, only ONE motor stops. The Slave keeps on rotating, till I hit the emergency stop.

Should be: If the Y Axis homes with both motors, if the Limit - is hit on the Master axis, the slave should stop too.

What am I doing wrong? Where could be the problem?
I feel like I tried all combinations of settings. Sadly most of the topics and solutios reference old Versions of the Pokeys Plugin or Mach4. Buttons or Checkboxes are missing, which might be the solution.
I attached the settings of both, Mach4 and the pokeys plugin.

Best Regards,
Markus
Re: Homing on Y Axis, 2 Motors (Slave), Limit Switch
« Reply #1 on: May 14, 2023, 11:49:05 PM »
I am having the same problem as you. Who can help us?
Re: Homing on Y Axis, 2 Motors (Slave), Limit Switch
« Reply #2 on: May 16, 2023, 11:58:13 AM »
Cause

To solve this problem I had to understand, that the pins for Homing, Limit + and Limit - are dedicated.
It is mentioned in the manual, but Mach4 and Pokeys Plugin let you chose to map those anyways.
Thats why I believed that the manual was outdated and I didn't noticed my mistake.

If you start homing, the settings are reset. If Y- Limit is hit, the master stops turning, the slave keeps rotating.


Solution

My workaround was to sacrifice one non-dedicated pin for the Y-Limit.
In my case i am sure, to never connect a LCD, so I chose Pin 28 for this.

Step 1) I disconnected "Axis 2 Limit -" and reconnected it to "LCD Connector, Pin 28"
Step 2) In Pokeys configuration I enabled Pin 28 as Digital Input and send the configuration to the device.
Step 3.1) In Mach4, Pokeys Plugin: I set Pin 28 also as Digital Input, and selected Pin 28 as Limit - for the Master and Slave Motor (In my case: Motor 1 and Motor 3 is my Y-Axis Duo)
Step 3.2) In Mach4, Control: I set Motor 1 as Master, Motor 3 as Slave.


Hope this helps.