Hello Guest it is October 20, 2019, 10:32:18 AM

Author Topic: Jerky motion on Gcode files  (Read 6710 times)

0 Members and 1 Guest are viewing this topic.

Jerky motion on Gcode files
« on: November 04, 2007, 06:59:54 PM »
I finally got my first files running, and I'm seeing really jerky motion on both the roadrunner file and an Artcam file.  The straight sections of both seem fine, but any curves and the motion seems as if its cutting a segmented line instead of a smooth curve.

On the roadrunner file it seems less jerky.  The Artcam file is considerably simpler- just a circle inside a rectangle.  The rectangle cuts fine, but the circle is jerky.  Both files seem to smooth out if I reduce cut speed, but its very jerky even at 100 ipm, which was very smooth with my SHopbot PR controller. 

What should I check?  I'm using the Post processor that Alan of Custom CNC provided, which is a Mach 3 post.  THe post saves the file with a .cnc suffix instead of a .tap, if that makes any difference.

My machine is a  P4 2ghz with 1mb, no network or internet connection.  My controller is an Ascension 1000 connected to Shopbot Vextra motors.  I get very smooth travel for all jogging, up thru speeds as high as 300 ipm. 

Thanks for your help!

Wayne C

Offline GaryB

*
  •  108 108
    • View Profile
Re: Jerky motion on Gcode files
« Reply #1 on: November 05, 2007, 09:17:52 AM »
Wayne its your CV check your settings
Beckwith Decor Products
ArtCam Trainer
Onsrud & Custom CNC tooling Distributor

Wichita/Derby Kansas
http://www.beckwithdecor.com

Offline PatM

*
  •  19 19
    • View Profile
Re: Jerky motion on Gcode files
« Reply #2 on: November 07, 2007, 10:01:51 AM »
Actually, I've just run into this as well (upgraded Mach about a week ago). I made a new job with VCarve 4.5 and my machine near shakes itself to death on what used to be real smooth curves. CV was the first thing I checked but the button is still glowng green.

Once I get this job off the table I'll try an older file (VCarve 4.0) and see if there's any difference. I checked the GCode and there's nothing in there that didn't appear in older files. Cant really see how GCode would mess up CV either (though I'm no expert).

This is under Mach 2.58

Offline PatM

*
  •  19 19
    • View Profile
Re: Jerky motion on Gcode files
« Reply #3 on: November 07, 2007, 10:23:19 AM »
Ok, got that job off the table and loaded up an older file that I know for sure was nice and smooth. Result was jerky.

I double checked the CV setting in the general tab and its on. I checked the backlash comp setting and it is off. I toggled the CV setting, shut down mach and restarted, no change. Rebooted the machine and no change.

I have to conclude the 2.58's CV is broken. Odd thing is that I ran several jobs under 2.58 without seeing this and now it won't go away.

The only change to my system was installing VCarve Pro 4.506 and its update to 4.507

Offline GaryB

*
  •  108 108
    • View Profile
Re: Jerky motion on Gcode files
« Reply #4 on: November 07, 2007, 10:53:32 AM »
Check your cv control in config and the cv feedrate on the settings page. Turn them off and put a g64 in you init string and you should be back to your original operation
Beckwith Decor Products
ArtCam Trainer
Onsrud & Custom CNC tooling Distributor

Wichita/Derby Kansas
http://www.beckwithdecor.com

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Jerky motion on Gcode files
« Reply #5 on: November 07, 2007, 01:57:40 PM »
I posted this http://www.machsupport.com/forum/index.php/topic,4694.0.html a few days ago but thus far have had no comments. I've had this happen a couple of times and the only way I've been able to resolve it is to re-install mach - it works for a while and then...
This seems to have become a feature since 2.56.1 which maybe coincidentally was the CV fix version after this thread http://www.machsupport.com/forum/index.php/topic,4113.0.html

Offline PatM

*
  •  19 19
    • View Profile
Re: Jerky motion on Gcode files
« Reply #6 on: November 07, 2007, 11:47:05 PM »
Check your cv control in config and the cv feedrate on the settings page. Turn them off and put a g64 in you init string and you should be back to your original operation

That's it!

Ran smooth as butter. Played around a bit and I think all thats required is just clicking off CV Feedrate on the settings tab. I left CV mode on, shut down Mach etc, loaded up the new (no G64) file that was jerky and it was jerky again. Looked at the settings tab and CV Feedrate was on. Clicked it off while machine was running and it instantly smoothed out.

With CV Feedrate off I chose "Save settings" from the config menu and found out that saving your settings turns CV Feedrate back on!

Offline Greolt

*
  •  956 956
    • View Profile
Re: Jerky motion on Gcode files
« Reply #7 on: November 10, 2007, 04:51:08 AM »


Check your cv control in config and the cv feedrate on the settings page.



I wish I had read this and Patm's post more carefully.  Would have saved me an afternoon of frustration.

Spent my time doing clean installs of every version I had on file, trying to find why all of a sudden CV would not work.

Kept going back to CV settings on the Config page but did not realise about the "CV Feedrate" on the settings page.

Never noticed it before.  Certainly did not change it myself.  Must be doing that by it's self.  I'll know what to look for in future.  ;D

Greg

Offline Greolt

*
  •  956 956
    • View Profile
Re: Jerky motion on Gcode files
« Reply #8 on: November 10, 2007, 03:36:02 PM »

This is a great forum with many helpful participants but sometimes it's better to go to the Yahoo group with a problem.

I posted on Yahoo about the CV Feedrate issue and Art fixed it straight away.  :D

Following is Arts Yahoo post regarding this.


Hi Guys:

Someone mentioned the CVFeedrate setting was turning on by itself, so if youve had CV trouble,
make sure its turned off on the settings tab, I revised 2.58 to keep it off unless turned on purposely..

Sorry about that, but my CV feedrate was set high enough it never took affect, but I suspect
some may have sucky CV as a result of that being on all the time..

Thanks,
Art
www.artofcnc.ca