Hello Guest it is May 28, 2024, 04:00:35 PM

Author Topic: Pokeys57E dead battery  (Read 5096 times)

0 Members and 1 Guest are viewing this topic.

Pokeys57E dead battery
« on: December 05, 2022, 09:35:18 PM »
I have been using a Pokeys57E for several years to interface between Mach3 and a custom control panel I made. It was working perfectly for a long time.  The other day it stopped working and it seemed like the shared messages between Mach and the 57E were not happening. I should mention that I have a bunch of logic that I uploaded using PoBlocks several years back.

My first thought was that the little coin cell on the back of the 57E is probably dead and the 57E has lost its memory. I contacted PoLabs or whatever they are called and they stated that the battery was only for the real time clock and would have no effect, and that my 57E was probably pooched and that I should purchase a new one. Tried a bunch of stuff nothing worked, however using the view mode in PoBlocks I could see all the logic working as it should when I exercised the inputs, finally I ignored their advice and changed the battery, it was near flat, and now everything is working like a champ again. So it appears that the battery does matter. YMMV