Hello Guest it is July 08, 2020, 01:30:00 AM

Author Topic: Galil locked up  (Read 4269 times)

0 Members and 1 Guest are viewing this topic.

Galil locked up
« on: October 31, 2007, 12:11:22 PM »
I have been testing a Galil system and thought I was close to having it operational. The jog is working, I was able to command position and move all axis, but my X axis was not moving the exact amount commanded. I went to the automatic setup and when I made it move a value of "1" I did not like the amount shown in the window that asked how much it moved so I cancelled instead of accepting. My axis has not moved by command since. I can still jog in all axis but cannot get it to move to a MDI commanded position. I have tried restarting my system, and even chosen an earlier setup to see if I inadvertently set a parameter wrong. Nothing I do seems to  be effective in making it move by command now. Any ideas?
Re: Galil locked up
« Reply #1 on: October 31, 2007, 07:26:23 PM »
I am not at my Machine though I did have to reinstall mach3 once to get clean scripts and parameters. If you do that remove your lic doc from your Mach3 directory, if you used default, then delete the directory completely after doing uninstall and you can start from scratch. You will also have to re download Galil plug in. Are you using Scales? With proper servo tuning I was able to get Mach3 to follow encoder counts exactly. Though the program will still fall short in MDI on a commanded move 10 - 14 thou. Re-enter the command a second time and it will go to that position within a half a thou. Still having trouble slight pausing between linear commands. Other than that running code great.
David
Re: Galil locked up
« Reply #2 on: November 10, 2007, 02:56:25 PM »
Hey all i see that this post gets read alot so I'll update here.
Yes I am using Galil PCI 1842 econo series. Also configured an DMC 1739 Optima (ISA).
Glentek velocity Amps, SEM 4nm 4000rpm Tack Feedback. Loop closed with 5v TTL scales to the Galil icm 1900.
Galil WSDK tuning software. Full sized Kent Milling machine 3 axis.
Tried this on a whim while I was rebuilding Ballscrews. Worked so well I sold my Camsoft control and I will soon be selling my WINGCNC control.
Both of which were the only real Galil to Gcode Alternative. Machine is as accurate as ever with Camsoft running Mach3. Code is being generated by Camsoft and Alibre/Visual mill. With scale feedback ,the 10th bearing retaining ring with planetary drill grid matched perfectly with the first drilled and thats with 5 dif operations and tool changes.
My advice, if you can tune motors and have a Galil card, you can replace an 80's control with confidence and Mach3

David ;D
Re: Galil locked up
« Reply #3 on: November 12, 2007, 12:50:25 PM »
dmerrl,
I see you mentioned wincnc as a Galil to gcode alternative.
I have wincnc running steppers but in the manual it shows an analog feature. Are you using Wincnc with analog servo drives? Any info is greatly appreciated.

Thanks,
Cutmore
Re: Galil locked up
« Reply #4 on: November 13, 2007, 11:41:29 AM »
Cutmore, The program I refered to is " WinGcnc" Google "JRACO" for more info.
Wincnc is something else all together
David
Re: Galil locked up
« Reply #5 on: November 13, 2007, 02:15:24 PM »
dmerrll,
Thanks for setting me straight,
I was hoping I could use my existing software for replacing the boss control on my mill.
Regards,
Cutmore