Hello Guest it is June 12, 2024, 08:04:23 PM

Author Topic: GCode not working properly in Mach3  (Read 6666 times)

0 Members and 1 Guest are viewing this topic.

GCode not working properly in Mach3
« on: August 04, 2022, 11:26:25 AM »
I'm having trouble with Mach3 and G-Code.
The computer I use for design has Mach3 installed on it and the results from this code shows just fine.
But when I load it on the PC that is actually connected to the CNC, one circle is HUGE!
its line 57 on the attached G-Code file:
G2 X74.3 Y34.353 I-26.675 J9.747

Units are in MM
that gcode line is supposed to make a 2in circle (50.8mm)
But on the CNC pc it tried to draw like a 2-foot circle!

Is there a setting I may have differently between the two?
Re: GCode not working properly in Mach3
« Reply #1 on: August 04, 2022, 03:15:06 PM »
ok so it appears to be a problem with Mach3 settings.
I reloaded Mach3 and poof, the gcode appears perfectly in the display window.
But then if I load the modified XML file that came with the BOB card... that one circle is gigantic.
So it definitely has to be a setting in Mach3

its this line in Gcode thats being misinterpreted: G2 X74.3 Y34.353 I-26.675 J9.747
Its supposed to be a circle 50.8mm in diameter, cut with a 6mm endmill... but it looks like it wants to cut a 500mm circle

Both XML files and the Gcode are attached.
I designed it in MM, and Mach3 is set to MM.
« Last Edit: August 04, 2022, 03:18:55 PM by JBWolf »
Re: GCode not working properly in Mach3
« Reply #2 on: August 04, 2022, 05:57:34 PM »
Hi,
the most likely fault is the Arc Mode setting.

Mach3 is natively in Incremental  Arc Mode and that will display normally. If however the machine is set to Absolute Arc Mode then huge arcs appear.

Craig
'I enjoy sex at 73.....I live at 71 so its not too far to walk.'
Re: GCode not working properly in Mach3
« Reply #3 on: August 05, 2022, 06:05:35 AM »
How do I change this?
Re: GCode not working properly in Mach3
« Reply #4 on: August 05, 2022, 06:47:04 AM »
I finally found it!
Its in General Config -> IJ Mode
Needs to = Incremental

Solved!
Thanks guys!