Hello Guest it is March 04, 2024, 02:28:36 AM

Author Topic: Pokeys57cnc Scaling moves  (Read 1012 times)

0 Members and 1 Guest are viewing this topic.

Pokeys57cnc Scaling moves
« on: June 10, 2022, 11:28:37 AM »
I have built a cnc from an old D&M trainer. I am using a pokeys57cnc board with Mach3. I have created a manual control panel and an automatic tool changer and everything works as it should. This has been a long process. I can jog in all directions and in different increments. I can move all axis in MDI and they move to position accurately to the commanded location.
However here is the problem I am experiencing: When I design something in Rhino and output it with Rhinocam the G code looks good. I load it in mach and it runs through the program with no errors but in changes my DRO's and screws up my G54 zeroed position? Then when you try to run the program it moves to what appears to be 10 times the programmed distance. If you set your jog increment to .01 it moves .1 but the DRO says it moved .01?
I then tried using the mach wizard and programmed a simple rectangular pocket and it did the same thing. I then manually programmed a simple square .1 deep and again did the same thing.
I have an old light machines (AKA Sherline) that I retrofitted years ago with just a cheap breakout board and everything else is the same. It works fine and I tried one of the programs that run on it and got the same result. I then took one of the programs that were made for the new machine and did a dry run on the Sherline and it worked fine. This leads me to believe there is something going on with the interface between Mach and Pokeys.

I am stumped and do not know where to go from here. You can see from the photo a lot has gone into this project and I am very close so I am hoping someone here can help me figure out what setting I am missing or where I went wrong????