Hello Guest it is March 02, 2024, 01:46:43 AM

Author Topic: [Mach4 & Pokeys57CNC] Error when starting homming or GCode  (Read 969 times)

0 Members and 1 Guest are viewing this topic.

Hey !
I am a beginner and this is my first CNC machine but i read a lot of topics on this forum and in the manuals.

I am starting to give up because i don't understand why machine stay idle :

What is my setup ?
-a Pokeys57CNC connected to leadshine stepper motors
-1 X axe with 2 limits switches and 1 home switch --> powered by the motor 2
-1 A axe without limit switches, it's a rotating head --> powered by the motor 0
(the Z axe isn't mounted yet )

What is working currently ?
-E-Stop, and limit switches wired and Mach4 detect when they are tripped
-Motor 0 and 2 are connected and i can move them using mach4 jogging interface
-I can execute basic lines of GCode in the MDI like
Code: [Select]
G0 X10 A20 F50 and the motors move accordingly

What is not working yet ?
-The Reference All Axes button dosen't do anything, a process start but nothing moves and i then have to press stop to kill it. I linked a screen capture and i paste the logs here (no message is prompted in the status bar).
Code: [Select]
[size=8pt]2022-05-05 14:26:06.285 - Logging Enabled.
2022-05-05 14:26:08.863 - [PoKeys]  [msg] PluginInstanceProcessAsyncMsg mInst = 0, msg = MSG_GUI_FOCUS (1030), wparam = 1, lparam = 0

2022-05-05 14:26:09.097 - API: mcAxisDerefAll(inst = 0) (unknown caller)
2022-05-05 14:26:09.097 - API: mcAxisDeref(inst = 0, axis = 0) (unknown caller)
2022-05-05 14:26:09.097 - [PoKeys]  [msg] PluginInstanceProcessMsg mInst = 0, msg = MSG_DREF_AXIS (1006), wparam = 0, lparam = 0

2022-05-05 14:26:09.097 - API: mcAxisDeref(inst = 0, axis = 3) (unknown caller)
2022-05-05 14:26:09.097 - [PoKeys]  [msg] PluginInstanceProcessMsg mInst = 0, msg = MSG_DREF_AXIS (1006), wparam = 3, lparam = 0

2022-05-05 14:26:09.097 - API: mcAxisHomeAll(inst = 0) (unknown caller)
2022-05-05 14:26:09.097 - Attempt transition from "Idle" on event "Home" command.cpp:1248
2022-05-05 14:26:09.097 - S_IDLE_on_exit
2022-05-05 14:26:09.097 - Signal id 1172, (Machine Idle), changed from HIGH to LOW.
2022-05-05 14:26:09.097 - ACION_start_homing
2022-05-05 14:26:09.097 - S_HOMING_on_entry
2022-05-05 14:26:26.499 - [PoKeys]  [msg] PluginInstanceProcessAsyncMsg mInst = 0, msg = MSG_GUI_FOCUS (1030), wparam = 0, lparam = 0[/size]

-When i try  to use the trace feature, the Gcode generated is always written with X and coordinates but i only move the X axe. Lateer i will add a Z translation but will never have a Y and i really need to use the trace wizzard. --> When the Gcode is read by Mach4 it fails because the Axe 1 is disabled.


-I also have the kbd48CNC Pokey keyboard and it isn't reconized in the Pokey Configuration program. It's an unrelated problem and i asked on Pokeys support but if anyone here add the same problem it could help me
 

Thanks a lot for your help !