Hello Guest it is July 18, 2024, 07:15:33 AM

Author Topic: Mach 3 feeds 20% slower than feedrate  (Read 12818 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 feeds 20% slower than feedrate
« on: October 25, 2021, 05:22:26 PM »
So I have a PC running W10, Parallel port to a breakout board and stepper drivers.   Now I did have my kernal speed set at 45khz and actual feedrate displayed on the screen matched the G code feedrate.   BUT, I found that on every direction change I was cumulatively loosing steps.   Not a backlash error, but cumulative on every change.  Now I have dropped my kernal spd down to 25khz, and I don't lose steps, but the feedrate is about 20% out.  maybe 18%  on a 20IPM command, the display is showing 18IPM  My jog moves also are off by the same percentage.  Any thoughts on this?  Maybe I should be 45Khz, but my breakout board or drivers can't handle?   I'm at a loss as I am trying to now get some precision work done.

Offline Graham Waterworth

*
  • *
  •  2,706 2,706
  • Yorkshire Dales, England
Re: Mach 3 feeds 20% slower than feedrate
« Reply #1 on: October 25, 2021, 05:38:15 PM »
Press the TAB key and check the jog values in there
Without engineers the world stops
Re: Mach 3 feeds 20% slower than feedrate
« Reply #2 on: October 25, 2021, 05:44:10 PM »
Press the TAB key and check the jog values in there

No it is not the jog value.   even when I  change jog value, actual IPM is slower than the commanded rate.   
Re: Mach 3 feeds 20% slower than feedrate
« Reply #3 on: October 25, 2021, 06:52:27 PM »
Sorry,  I can't edit post,  Computer is running XP  not W10.

Offline Graham Waterworth

*
  • *
  •  2,706 2,706
  • Yorkshire Dales, England
Re: Mach 3 feeds 20% slower than feedrate
« Reply #4 on: October 25, 2021, 07:07:27 PM »
Depending on your steps per setting and the 25Khz it could be that the pulse rate is not fast enough to hit top speed.

Put the kernal speed up to 35Khz and see if that improves the problem.

Do not forget that you must restart PC and re-tune the motors after a speed kernal change.
Without engineers the world stops
Re: Mach 3 feeds 20% slower than feedrate
« Reply #5 on: October 25, 2021, 07:18:51 PM »
Depending on your steps per setting and the 25Khz it could be that the pulse rate is not fast enough to hit top speed.

Put the kernal speed up to 35Khz and see if that improves the problem.

Do not forget that you must restart PC and re-tune the motors after a speed kernal change.

Yes.  when I do that, the feedrates match more closely.  There about bang on at 45Khz.  BUT, and setting above 25Khz is causing cumulative loss of steps on direction changes.   like .00005" every 4 direction changes.  This is not backlash.  I can use a .001" step Jog,  go 4x one way, 4x back the other way, and the more I do it, the larger the error gets.  My steppers are not stopping in the same spot.  I can physically see them stopping different too   Just trying to see where the main problem is.   I am starting to think my Stepper drivers can't handle faster than 25Khz, since Mach3 knows and displays that it can't maintain feedrate at 25Khz.  And it isn't a running out of pulsetrain timing thing, because 1IPM or 10IPM or 40IPM,  The error is same percentage