Hello Guest it is October 22, 2021, 09:12:46 PM

Author Topic: Mach 3 randomly doesn't allow me enable soft limits  (Read 152 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 randomly doesn't allow me enable soft limits
« on: May 25, 2021, 09:15:56 AM »
Hi guys,

Mach 3 doesn't allow me to enable soft limits in a random way. After homing, and moving absolute position within the soft limits, It keeps telling me "machine out of limits for for soft limit activation".
Some times I can activate it before homing.

Attached: xml file and screenshots of configuration.


As you can see, I have homing offests, so that machine has 10mm before homing switch on X and Y axis, and 15mm in the Z axis. Homing and --Limit for X and Y are shared, for Z homing and ++Limit is shared.

 



SETUP:

Mach 3 Version R3.043.062

Win 10 x64

NUVM V2 Controllor with latest plugin

DM542 stepper drivers, 200°/rev steppers ; 2000 steps per millimeter

A axis slaved to Y axis,

UNITS: MILLIMETERS
Strange behaviour trying to backoff more from homing switch + VBA
« Reply #1 on: May 25, 2021, 09:37:09 AM »
Hi guys,

I have inductive NPN NC sensors for homing and limit (shared).

When Z axis do the homing procedures, it doesn't backoff enough (and/or quick enough), so the axis backs off until a tiny zone in witch the switch triggers on and off.

All cables are shielded and grounded on one side, this happens even with VFD disconnected, and when the spindle is at maximum the switches doesn't trip. Debounce at 2500.

I tried a VB script to back off more, moving fast the homed axis away, up to the Axis absolute machine zero (I have homing offesets). And however this is something I would like to have apart from preventing the Z issue.

I tried a script found on the internet and the Z works ok (in fact, the entire homing goes ok, each axis homes and then moves away fast).

But after performing this script, the controller doesn't allow me to ZERO the axis and doesn't accept MDI commands. In order to fix this I have to push RESET several times (sometimes works, sometimes it doesn't).

A axis is non rotary and slaved to Y, each with his own homing switch.

Code used:

Code: [Select]
DoButton( 24 ) 'Ref Z

    While IsMoving
    Wend
   
    Code " G53 G0 Z0 " 'moves Z to machine 0
   
    While IsMoving
    Wend
   
    DoOEMButton(135) 'Zero Z
   
   
   
DoButton( 22 ) 'Ref X


    While IsMoving
    Wend
   
    Code " G53 G0 X0 " 'moves X to machine 0
   
    While IsMoving
    Wend
   
    DoOEMButton(133) 'Zero X




DoButton( 23 ) 'Ref Y
DoButton( 25 ) 'Ref A


    While IsMoving
    Wend
   
    Code " G53 G0 Y0 " 'moves Y to machine 0
   
    While IsMoving
    Wend
   
    DoOEMButton(134) 'Zero Y

It's like it remains hanging in a While IsMoving, or something. Later I'll try mess around with a friend who used VBA a lot in the past.

Attached: XML config file and some screenshots.



SETUP:

Mach 3 Version R3.043.062

Win 10 x64

NUVM V2 Controllor with latest plugin

DM542 stepper drivers, 200°/rev steppers ; 2000 steps per millimeter

A axis slaved to Y axis,

UNITS: MILLIMETERS

Offline Tweakie.CNC

*
  • *
  •  8,836 8,836
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach 3 randomly doesn't allow me enable soft limits
« Reply #2 on: May 25, 2021, 10:08:31 AM »
I have sent you a PM.

Tweakie.
KEEP SAFE !