Hello Guest it is August 07, 2020, 05:58:11 PM

Author Topic: Odd Z movement  (Read 3006 times)

0 Members and 1 Guest are viewing this topic.

Odd Z movement
« on: April 07, 2006, 07:50:51 AM »
I am experiencing an odd Z movement with the code posted below. The code is only the begining few blocks of a profiled surface.

The peculiar Z movement seems to occur after line 70 having driven to 1.9685 (I know its a funny number but it is a function bug in Dolphin CAM I think)
then for some reason Z goes to 1" until the next Z command occurs

Stepping the blocks one at a time shows this up. But it is not consistant as sometimes it does not occur.

I have run the prgram on two different PC's with the same result.

Any advice on what might be happening?

Code:
 Produced       :- 10:28:57  Friday, April 07, 2006 )
( CNC File       :- joggle1 )
( Post Processor :- M_MACH_3 )
( Part Number ID :-  )
(Program Number :- O100  )
N60 G00 G20 G17 G90 G40 G49 G80
N70 G00 Z1.9685
N80 X0.0 Y0.0 Z2.0
N90 M06 T2 G43 H2  ( End Mill )
N100 G94 S1000 M03
N110 M08
N120 X0.0 Y-0.125 Z2.0
N130 X0.0 Y-0.125 Z0.0625
N140 G01 X0.0 Y-0.125 Z-0.0024 F2.0
N150 X0.0 Y-0.3576 Z-0.0024
N160 X0.0 Y-0.3676 Z-0.0024
Re: Odd Z movement
« Reply #1 on: April 07, 2006, 08:00:08 AM »
It's always the way isn't it ....... make a post and then see the answer!!

Its the G43 tool length offset that seems to be doing it .... but why I see it sometimes and not others is a bit confusing.
Re: Odd Z movement
« Reply #2 on: April 07, 2006, 09:10:44 AM »
Now I have started this hare running I get more questions than answers!

Looking at the Mach3 Offset page I see the Z offset as 1.000 but the button to toggle the offset on/off does not seem to have any affect.... the LED's remaon permanently lit.  Why?

I then started to think why was the G43 command there anyway as I had not specified any Z offset to be used. The tool definition has its length set to 1.000" but that is all. So where is the Z offset figure generated from?

Perhaps I do not understand the significance of the tool length definition?

When I set the machine up I jog the Z axis down to get the tip of the tool touching the work surface ( zero plane) and set Z to zero. Set the X and Y up and set them to zero, regen the tool path and the work cuts at the correct plane. So I seem to be doing it OK but now I am unsure I understand what I am doing! ..... in respect of the Z axis and the tool length and offset.

Anybody care to give an idiots guide?
Re: Odd Z movement
« Reply #3 on: April 07, 2006, 04:18:56 PM »
IT is going to take me a bit but I think I am going to have to make a video showing how to do tool offsets
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Odd Z movement
« Reply #4 on: April 07, 2006, 04:40:04 PM »
That would be very welcomed indeed.