Hello Guest it is May 08, 2021, 09:57:11 PM

Author Topic: Keyboard Inputs plugin issues  (Read 108 times)

0 Members and 1 Guest are viewing this topic.

Keyboard Inputs plugin issues
« on: April 20, 2021, 06:15:46 AM »
Hi guys,
I upgraded my mill a few days ago from Mach 3 with parallel interface to the control system to Mach 4 and ESS.

The control system is the old one from "www.einfach-cnc" and i use the old handwheel from this company too.
The handweel has a USB connection to the computer and electric connection to the control and therefore ESS. Via the electric interface just the MPG and a reset button for the control system are connected and both work well.

All other buttons (Start/Pause/Stop Gcode, selection for Axis, Step increments,...) are connected via USB to the computer and therefore should work via the keyboard Input plugin. More or less as they did on Mach 3. I watched the "Keyboard Mapping" video and got a basic understanding for the LUA programming. I tried to mapp the buttons via the keyboards input plugin and it worked for some buttons without any problems (e.g. pressing on "Start G Code" at my handwheel shows "F7" or so in the plugin). Fine - i created a LUA code and it works already. I can start and pause the Gcode.

Now to the issue: The plugin recognizes many buttons just as "Left ALT (164)". Therefore they cant be "separated" by the plugin and therefore i cant use them. I am sure that the USB Handwheel in fact sends different signals for each button or it would have never worked in Mach 3. So it must have to do with the Keyboard Inputs plugin or some other setting e.g. on the computer. How can i fix this problem? Thanks!
Wolfgang
Re: Keyboard Inputs plugin issues
« Reply #1 on: April 22, 2021, 09:50:55 AM »
Dear all,
I did now test it a bit more in detail using a online keyboard grabber. The grabber detected all inputs without any problem.
It shows that all inputs the keyboard plugin cant recognize are simply ALT + "whatever" inputs. In Detail:
X - F9
Y - F10
Z - F11
Set X - ALT+X
Set Y - ALT+Y
Set Z - ALT+Z
Jog Cont - ALT+K
Jog Step - ALT+S
Jog 1.0 - ALT+1
Jog 0.1 - ALT+2
Jog 0.01 - ALT+3
Measure Tool - ALT+V
Stop Gcode Execution - ALT+/
Start Gcode Execution - F7
Pause Gcode Execution - F8
Spindel RPM + - ALT+P
Spindle RPM - - ALT+M
Feedrate + ALT++
Feedrate - ALT+-
And the keyboard inputs plugin always just recognizes the ALT button but not the additional one. Therefore just the F7-F11 commands work.
How can i fix the issue?
Thanks!
Wolfgang
Re: Keyboard Inputs plugin issues
« Reply #2 on: April 22, 2021, 11:26:48 AM »
Try this... use your normal PC keyboard to enter the letter/character assigned to the button press into the keyboard plugin, and then select the Alt option within the keyboard plugin. I have attached an example