Hello Guest it is December 04, 2021, 01:09:37 PM

Author Topic: Epid error need to reset mach3  (Read 166 times)

0 Members and 1 Guest are viewing this topic.

Epid error need to reset mach3
« on: April 18, 2021, 12:26:42 PM »
Hi chaps. I am running a CS-Labs CSMIO/1P-M. and Mach3. For some reason my router was adding steps on when cutting on the Z axis. So after checking all the fittings and finding nothing, I swapped out the motor for a closed loop system with a new motor driver. However I am now getting the Epid error code when I try to jog the z axis. Ok this must be due to the closed loop system. But is there a way to stop the error coming up. Thanks. Michael

Offline TPS

*
  •  2,212 2,212
    • View Profile
Re: Epid error need to reset mach3
« Reply #1 on: April 19, 2021, 01:32:22 AM »
in the first step, a closed Loop Motor is the same for Mach3/CSlab, because it is only Streaming step and dir signals
to the stepper Controller. only the stepper Controller has control over the closed Loop.so in this case i would search
at stepper Controller side. had also some Trouble with CSLab and Epid error. CSLab recomend to use Mach Version 043.022.
i do not think that the Controller was "adding" step's, this normaly allways means it is loosing steps.
anyhow there is no way to "turn off" this EPid error message on Mach/CSLab side.
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Epid error need to reset mach3
« Reply #2 on: April 19, 2021, 03:58:45 AM »
Hi, thanks for your input. So did you change the version of mach3. And did it correct the error.