Hello Guest it is May 09, 2021, 09:19:37 PM

Author Topic: How to Sett Tool #1 on Startup in Mach3  (Read 78 times)

0 Members and 1 Guest are viewing this topic.

How to Sett Tool #1 on Startup in Mach3
« on: March 11, 2021, 06:11:24 AM »
I have a router with two spindles as the easiest way to implement a simple tool changer.  It runs Mach3 with negative tool lengths.

Mach3 starts with the tool # set to 0 which has length 0 which is always wrong.  If I forget to set Tool 1 before I set my work zero position then as soon as the G Code sets Tool 1, my work zero is now below the bed of the machine with undesirable consequences! 

As a way round this, I thought I would set the tool # to be 1 in RefAllHome using SetCurrentTool(1).  This works as Tool 1 details are shown on the Program Run screen, but Mach3 does not seem to pick up the tool length at this point so I still have the same problem.  If I do a manual G43T1, (pick up the tool length for this tool from the tool table) all is happy, so how do I do the equivalent of G43H1 from within RefAllHome?  Neither Code "G43H1" nor Code("G43H1") do anything at all.

Is there a better way to solve my problem please?  If not, how do I get Mach3 to recognise the length of Tool1 from the tool table having selected it it RefAllHome?

Many thanks, Nick

Offline TPS

*
  •  2,124 2,124
    • View Profile
Re: How to Sett Tool #1 on Startup in Mach3
« Reply #1 on: March 11, 2021, 06:21:30 AM »
a:
Code: [Select]
  SetOEMDro(824,1)

should set everything.

can also set in Config -> General Config -> ToolDro persistent
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: How to Sett Tool #1 on Startup in Mach3
« Reply #2 on: March 12, 2021, 09:22:09 AM »
I have used the "  SetOEMDro(824,1)" and it works!  Huge thank you, that has been painful but only broke one cutter!