Hello Guest it is April 18, 2021, 03:12:34 PM

Author Topic: Losing axis calibration when jogging mach3  (Read 99 times)

0 Members and 1 Guest are viewing this topic.

Losing axis calibration when jogging mach3
« on: February 16, 2021, 01:25:52 AM »
Hello, having a problem losing axis calibration after jogging.. I have a Sherline 5400 cnc (inch) mill with a the stock Sherline computer driver combo and UC100 usb controller, I am running windows 10 and Mach version R3.043.062 with the Sherline (inch) .xml I downloaded from the Mach ftp site.

I am using a Dial indicator and a 4" gauge block for the axis calibration I am able to calibrate the x axis within a 10th of 1/1000th in both directions, but once I jog the axis around and go back into axis calibration its off and its always off a random measurement's never the same.

I have uploaded and attached screens of all my settings hopefully someone can point out something I did wrong lol ;D.

One thing I did notice is that Sherline says the pins need to be Step Low active, and the Mach Sherline .xml had them checked to reflect that statement, but my steppers will not move unless left unchecked in Step High state for some reason.

I have tried many solutions I've read about on the forums, none seem to work, even installing 3 different mach3 versions thinking it may be a bug. Any help would be greatly appreciated, thanks in advance.   


                                                                                                   

Offline TPS

*
  •  2,110 2,110
    • View Profile
Re: Losing axis calibration when jogging mach3
« Reply #1 on: February 18, 2021, 08:51:25 AM »
your Problem is normaly caused by loosing steps and/or mechanical Problem.

do a calibraiton test of the whole range of your table, for this check a tapemeter should be ok.
repeat this a couple of times and check you get allways the same result. 
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Losing axis calibration when jogging mach3
« Reply #2 on: February 20, 2021, 12:54:32 AM »
You may be right, I think it could be a mechanical issue the other night I got fed up and switched to linuxcnc, which I hate btw, thinking it could be software or the uc100 controller, but failed to set it up correctly with mint and ubuntu...

So I thought, screw it, tore my axis's down again and found that my backlash nuts have tightened or moved somehow. That may be the problem because the stock Sherline motors aren't that powerful. My machine could have been missing steps because the lead screw nuts are too tight.

I'll update once I get this infernal machine back together and get windows and Mach3 reinstalled.
Thanks for the advice.